summaryrefslogtreecommitdiff
path: root/Docs/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com/kent-amd64.(none)>2007-11-02 12:44:48 +0100
committerunknown <kent@mysql.com/kent-amd64.(none)>2007-11-02 12:44:48 +0100
commit9dc0282731aaceaa0e76049be7f9f01677b1d73b (patch)
tree8ba8cf80a514f3019a3f5b300b2e17dc4de08ab4 /Docs/Makefile.am
parent1de7e5c09f915333cd21fc3786259a3967ddf69a (diff)
parent8f0409413450531f295671c01386293d3919e9ac (diff)
downloadmariadb-git-9dc0282731aaceaa0e76049be7f9f01677b1d73b.tar.gz
Merge mysql.com:/home/kent/bk/bug25205/mysql-4.1-build
into mysql.com:/home/kent/bk/bug25205/mysql-5.0-build BitKeeper/deleted/.del-generate-text-files.pl: SCCS merged Docs/Makefile.am: SCCS merged
Diffstat (limited to 'Docs/Makefile.am')
-rw-r--r--Docs/Makefile.am39
1 files changed, 4 insertions, 35 deletions
diff --git a/Docs/Makefile.am b/Docs/Makefile.am
index 369e02e4654..95a04862406 100644
--- a/Docs/Makefile.am
+++ b/Docs/Makefile.am
@@ -13,50 +13,19 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-noinst_SCRIPTS = Support/generate-text-files.pl
-
-EXTRA_DIST = $(noinst_SCRIPTS) manual.chm mysql.info INSTALL-BINARY
-
-TXT_FILES= ../INSTALL-SOURCE ../INSTALL-WIN-SOURCE \
- INSTALL-BINARY ../support-files/MacOSX/ReadMe.txt
-
-all-local: $(TXT_FILES)
+EXTRA_DIST = mysql.info INSTALL-BINARY
# make sure that "make install" installs the info page, too
# automake only seems to take care of this automatically,
# if we're building the info page from texi directly.
-install-data-hook: $(srcdir)/mysql.info
+install-data-hook: $(srcdir)/mysql.info $(srcdir)/INSTALL-BINARY
$(mkinstalldirs) $(DESTDIR)$(infodir)
$(INSTALL_DATA) $(srcdir)/mysql.info $(DESTDIR)$(infodir)
+ $(INSTALL_DATA) $(srcdir)/INSTALL-BINARY $(DESTDIR)$(infodir)
uninstall-local:
@RM@ -f $(DESTDIR)$(infodir)/mysql.info
-
-# Problems with "make distclean", works differently for make files
-# generated by different versions of the automake. Some require the
-# generated files explicitly in DISTCLEANFILES.
-DISTCLEANFILES = $(TXT_FILES)
-
-# This target is not used in builds, just for convinience
-CLEAN_FILES: $(TXT_FILES)
- touch $(TXT_FILES)
-
-GT = $(srcdir)/Support/generate-text-files.pl
-
-../INSTALL-SOURCE: $(srcdir)/mysql.info $(GT)
- perl -w $(GT) $(srcdir)/mysql.info "installing-source" "windows-source-build" > $@
-
-../INSTALL-WIN-SOURCE: $(srcdir)/mysql.info $(GT)
- perl -w $(GT) $(srcdir)/mysql.info "windows-source-build" "post-installation" > $@
-
-# We put the description for the binary installation here so that
-# people who download source wont have to see it. It is moved up to
-# the toplevel by the script that makes the binary tar files.
-INSTALL-BINARY: $(srcdir)/mysql.info $(GT)
- perl -w $(GT) $(srcdir)/mysql.info "installing-binary" "installing-source" > $@
-
-../support-files/MacOSX/ReadMe.txt: $(srcdir)/mysql.info $(GT)
- perl -w $(GT) $(srcdir)/mysql.info "mac-os-x-installation" "netware-installation" > $@
+ @RM@ -f $(DESTDIR)$(infodir)/INSTALL-BINARY
# Don't update the files from bitkeeper
%::SCCS/s.%