summaryrefslogtreecommitdiff
path: root/Docs/Makefile.am
diff options
context:
space:
mode:
authorunknown <jcole@mugatu.spaceapes.com>2002-03-17 05:30:03 -0600
committerunknown <jcole@mugatu.spaceapes.com>2002-03-17 05:30:03 -0600
commit0224a6da7d8a87718992448180e78afe2d01823a (patch)
tree048011983a229fc7edc84432b2727659005c22bc /Docs/Makefile.am
parentade0c20727857164efc25d5b21a83177ee5c2ba8 (diff)
downloadmariadb-git-0224a6da7d8a87718992448180e78afe2d01823a.tar.gz
Added Makefile.am targets for internals.texi.
Cleaned up internals.texi, changed tabs to spaces. Docs/Makefile.am: Added Makefile.am targets for internals.texi. Docs/internals.texi: Cleanups, replaced tabs with spaces.
Diffstat (limited to 'Docs/Makefile.am')
-rw-r--r--Docs/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/Docs/Makefile.am b/Docs/Makefile.am
index b9feeec04db..156d26a9a02 100644
--- a/Docs/Makefile.am
+++ b/Docs/Makefile.am
@@ -158,6 +158,53 @@ manual_letter.de.ps: manual.de.texi include.texi
#
+# Internals Manual
+#
+
+# GNU Info
+internals.info: internals.texi include.texi
+ cd $(srcdir) && $(MAKEINFO) --no-split -I $(srcdir) $<
+
+# Plain Text
+internals.txt: internals.texi include.texi
+ cd $(srcdir) && \
+ $(MAKEINFO) -I $(srcdir) --no-headers --no-split --output $@ $<
+
+# HTML, all in one file
+internals.html: internals.texi include.texi $(srcdir)/Support/texi2html
+ cd $(srcdir) && @PERL@ $(srcdir)/Support/texi2html $(TEXI2HTML_FLAGS) $<
+internals_toc.html: internals.html
+
+# PDF, Portable Document Format
+internals.pdf: internals.texi
+ sed -e 's|@image{[^}]*} *||g' <$< >internals-tmp.texi
+ pdftex --interaction=nonstopmode internals-tmp.texi
+ texindex internals-tmp.??
+ pdftex --interaction=nonstopmode internals-tmp.texi
+ texindex internals-tmp.??
+ pdftex --interaction=nonstopmode internals-tmp.texi
+ mv internals-tmp.pdf $@
+ rm -f internals-tmp.*
+ touch $@
+
+# Postscript, A4 Paper
+internals_a4.ps: internals.texi include.texi
+ TEXINPUTS=$(srcdir):$$TEXINPUTS \
+ MAKEINFO='$(MAKEINFO) -I $(srcdir)' \
+ $(TEXI2DVI) --batch --texinfo --quiet '@afourpaper' $<
+ $(DVIPS) -t a4 internals.dvi -o $@
+ touch $@
+
+# Postscript, US Letter Paper
+internals_letter.ps: internals.texi include.texi
+ TEXINPUTS=$(srcdir):$$TEXINPUTS \
+ MAKEINFO='$(MAKEINFO) -I $(srcdir)' \
+ $(TEXI2DVI) --batch $<
+ $(DVIPS) -t letter internals.dvi -o $@
+ touch $@
+
+
+#
# Miscellaneous
#