summaryrefslogtreecommitdiff
path: root/Docs/Makefile.am
diff options
context:
space:
mode:
authorjcole@mugatu.spaceapes.com <>2002-03-14 04:11:20 -0600
committerjcole@mugatu.spaceapes.com <>2002-03-14 04:11:20 -0600
commitb285fc7940272bf4a9e83a8bae9cd982aeaf0748 (patch)
tree7546a66fb3c570a931f7af0b4a5fe0b456c5fcbb /Docs/Makefile.am
parent54b95c7f9adb4b50218fe38d1a43db7624bf304a (diff)
downloadmariadb-git-b285fc7940272bf4a9e83a8bae9cd982aeaf0748.tar.gz
Cleaned up rules in Docs/Makefile.am.
Diffstat (limited to 'Docs/Makefile.am')
-rw-r--r--Docs/Makefile.am33
1 files changed, 16 insertions, 17 deletions
diff --git a/Docs/Makefile.am b/Docs/Makefile.am
index 726a35a8e54..b9feeec04db 100644
--- a/Docs/Makefile.am
+++ b/Docs/Makefile.am
@@ -69,21 +69,21 @@ manual_toc.html: manual.html
# PDF, Portable Document Format
manual.pdf: manual.texi
- cat manual.texi | sed -e 's|@image{[^}]*} *||g' > manual-tmp.texi
+ sed -e 's|@image{[^}]*} *||g' <$< >manual-tmp.texi
pdftex --interaction=nonstopmode manual-tmp.texi
texindex manual-tmp.??
pdftex --interaction=nonstopmode manual-tmp.texi
texindex manual-tmp.??
pdftex --interaction=nonstopmode manual-tmp.texi
- mv manual-tmp.pdf manual.pdf
+ mv manual-tmp.pdf $@
rm -f manual-tmp.*
touch $@
# XML, DocBook 4.0
mysql.xml: manual.texi include.texi
- $(MAKEINFO) --force --no-ifinfo --docbook manual.texi
- mv mysql.xml mysql-tmp.xml
- Support/docbook-fixup.pl <mysql-tmp.xml >mysql.xml
+ $(MAKEINFO) --force --no-ifinfo --docbook $<
+ mv $@ mysql-tmp.xml
+ Support/docbook-fixup.pl <mysql-tmp.xml >$@
rm -f mysql-tmp.xml
# Postscript, A4 Paper
@@ -123,21 +123,21 @@ manual_toc.de.html: manual.html
# PDF, Portable Document Format
manual.de.pdf: manual.de.texi
- cat manual.de.texi | sed -e 's|@image{[^}]*} *||g' > manual-tmp.texi
+ sed -e 's|@image{[^}]*} *||g' <$< >manual-tmp.texi
pdftex --interaction=nonstopmode manual-tmp.texi
texindex manual-tmp.??
pdftex --interaction=nonstopmode manual-tmp.texi
texindex manual-tmp.??
pdftex --interaction=nonstopmode manual-tmp.texi
- mv manual-tmp.pdf manual.de.pdf
+ mv manual-tmp.pdf $@
rm -f manual-tmp.*
touch $@
# XML, DocBook 4.0
mysql.de.xml: manual.de.texi include.texi
- $(MAKEINFO) --force --no-ifinfo --docbook manual.de.texi
- mv mysql.de.xml mysql-tmp.xml
- Support/docbook-fixup.pl <mysql-tmp.xml >mysql.de.xml
+ $(MAKEINFO) --force --no-ifinfo --docbook $<
+ mv $@ mysql-tmp.xml
+ Support/docbook-fixup.pl <mysql-tmp.xml >$@
rm -f mysql-tmp.xml
# Postscript, A4 Paper
@@ -163,18 +163,17 @@ manual_letter.de.ps: manual.de.texi include.texi
# Target to produce NuSphere Manual
nusphere.pdf: manual.texi
- cat manual.texi \
- | sed -e 's/@example/@smallexample/g' \
- -e 's/@end example/@end smallexample/g' \
- -e 's/@c ifnusphere //g' \
- -e 's|@image{[^}]*} *||g' \
- > manual-tmp.texi
+ sed -e 's/@example/@smallexample/g' \
+ -e 's/@end example/@end smallexample/g' \
+ -e 's/@c ifnusphere //g' \
+ -e 's|@image{[^}]*} *||g' \
+ <$< >manual-tmp.texi
pdftex --interaction=nonstopmode manual-tmp.texi
texindex manual-tmp.??
pdftex --interaction=nonstopmode manual-tmp.texi
texindex manual-tmp.??
pdftex --interaction=nonstopmode manual-tmp.texi
- mv manual-tmp.pdf nusphere.pdf
+ mv manual-tmp.pdf $@
rm -f manual-tmp.*
touch $@