summaryrefslogtreecommitdiff
path: root/Docs/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com/kent-amd64.(none)>2007-11-02 12:33:16 +0100
committerunknown <kent@mysql.com/kent-amd64.(none)>2007-11-02 12:33:16 +0100
commitacea5f18bf48e4614f18eada00636daf1e083a9d (patch)
treea0b0112d1b7569bc6460f7326bc4540621db1aca /Docs/Makefile.am
parentafa5d5a6da8d85391e12182e0bf7531dcdeaec80 (diff)
parent5ee36c1d971d2f151c615ab2c14f704c7f8cca09 (diff)
downloadmariadb-git-acea5f18bf48e4614f18eada00636daf1e083a9d.tar.gz
Merge mysql.com:/home/kent/bk/bug25205/mysql-4.0
into mysql.com:/home/kent/bk/bug25205/mysql-4.1-build
Diffstat (limited to 'Docs/Makefile.am')
-rw-r--r--Docs/Makefile.am34
1 files changed, 4 insertions, 30 deletions
diff --git a/Docs/Makefile.am b/Docs/Makefile.am
index ab4288ba9d9..02702d77fed 100644
--- a/Docs/Makefile.am
+++ b/Docs/Makefile.am
@@ -14,45 +14,19 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-noinst_SCRIPTS = Support/generate-text-files.pl
-
-EXTRA_DIST = $(noinst_SCRIPTS) mysql.info INSTALL-BINARY
-
-TXT_FILES= ../INSTALL-SOURCE ../INSTALL-WIN-SOURCE \
- INSTALL-BINARY ../support-files/MacOSX/ReadMe.txt
-
-all-local: $(TXT_FILES)
+EXTRA_DIST = mysql.info INSTALL-BINARY
# make sure that "make install" installs the info page, too
# automake only seems to take care of this automatically,
# if we're building the info page from texi directly.
-install-data-hook: $(srcdir)/mysql.info
+install-data-hook: $(srcdir)/mysql.info $(srcdir)/INSTALL-BINARY
$(mkinstalldirs) $(DESTDIR)$(infodir)
$(INSTALL_DATA) $(srcdir)/mysql.info $(DESTDIR)$(infodir)
+ $(INSTALL_DATA) $(srcdir)/INSTALL-BINARY $(DESTDIR)$(infodir)
uninstall-local:
@RM@ -f $(DESTDIR)$(infodir)/mysql.info
-
-# This target is not used in builds, just for convinience
-CLEAN_FILES: $(TXT_FILES)
- touch $(TXT_FILES)
-
-GT = $(srcdir)/Support/generate-text-files.pl
-
-../INSTALL-SOURCE: $(srcdir)/mysql.info $(GT)
- perl -w $(GT) $(srcdir)/mysql.info "installing-source" "windows-source-build" > $@
-
-../INSTALL-WIN-SOURCE: $(srcdir)/mysql.info $(GT)
- perl -w $(GT) $(srcdir)/mysql.info "windows-source-build" "post-installation" > $@
-
-# We put the description for the binary installation here so that
-# people who download source wont have to see it. It is moved up to
-# the toplevel by the script that makes the binary tar files.
-INSTALL-BINARY: $(srcdir)/mysql.info $(GT)
- perl -w $(GT) $(srcdir)/mysql.info "installing-binary" "installing-source" > $@
-
-../support-files/MacOSX/ReadMe.txt: $(srcdir)/mysql.info $(GT)
- perl -w $(GT) $(srcdir)/mysql.info "mac-os-x-installation" "netware-installation" > $@
+ @RM@ -f $(DESTDIR)$(infodir)/INSTALL-BINARY
# Don't update the files from bitkeeper
%::SCCS/s.%