summaryrefslogtreecommitdiff
path: root/Docs/Makefile.am
diff options
context:
space:
mode:
authorunknown <jcole@tetra.bedford.progress.com>2000-09-05 10:46:24 -0500
committerunknown <jcole@tetra.bedford.progress.com>2000-09-05 10:46:24 -0500
commitb981da0346492d34c5c0c2fde6af8a7086ec423f (patch)
tree3ce7cd0cab644e7a681f8c6b557a9b2fe9b7b878 /Docs/Makefile.am
parent30629e906065b39e1b3e00f69c681a82cdf39a73 (diff)
downloadmariadb-git-b981da0346492d34c5c0c2fde6af8a7086ec423f.tar.gz
Added target for printed manual pdf for NuSphere.
Docs/Makefile.am: Added target for printed manual pdf.
Diffstat (limited to 'Docs/Makefile.am')
-rw-r--r--Docs/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Docs/Makefile.am b/Docs/Makefile.am
index 1b5d77dea77..8f5276b1b22 100644
--- a/Docs/Makefile.am
+++ b/Docs/Makefile.am
@@ -66,6 +66,16 @@ manual.pdf: manual.texi
rm -f manual-tmp.* ; \
touch $@
+# Target to produce NuSphere Manual
+print-manual.pdf: manual.texi
+ cat manual.texi | sed -e 's|@image{[^}]*} *||g' > manual-tmp.texi; \
+ pdftex --interaction=nonstopmode '\input manual-tmp.texi'; \
+ pdftex --interaction=nonstopmode '\pdfcompresslevel=9' \
+ '\input manual-tmp.texi'; \
+ mv manual-tmp.pdf $@; \
+ rm -f manual-tmp.* ; \
+ touch $@
+
# The texi2dvi gives a lot of harmless errors. Just ignore them unless
# you want to help with the typesetting part.
# This is the European papersize version