summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <guilhem@gbichot3.local>2006-09-15 15:15:24 +0200
committerunknown <guilhem@gbichot3.local>2006-09-15 15:15:24 +0200
commit6e10407c2b34aad5324a13d5f9243c944614d2a5 (patch)
tree4a806d99e2eb9e6c98fe6213c4fa5ea9d6402a44 /Makefile.am
parentaa856526ee6a99fd09c90228617c0534a7c5d076 (diff)
downloadmariadb-git-6e10407c2b34aad5324a13d5f9243c944614d2a5.tar.gz
WL#3504 "plugin actions for engines' and plugins' unit tests"
for push in 5.1 (I will inform Trudy). Storage engines and plugins can now have unit tests to test their components; such test must be an executable C/C++ program which name ends with '-t' and which is obeys the mytap protocol, it must be stored in the storage engine's or plugin's source directory (storage/<engine> or plugin/<plugin>) or any subdirectories of this. The top-level Makefile target "test-unit" will run all unit tests: it will scan the engines' and plugins' directories, recursively, and execute all executable files which name ends with '-t'." Makefile.am: "unittest" directory must be built before "storage" and "plugin" because the unit tests in these directories may need libmytap.a which is in unittest/mytap. config/ac-macros/plugins.m4: When enabling engine "X", we add "../storage/X" to the unit tests directories which unittest/unit.pl should traverse looking for tests to execute. Same for plugins. unittest/Makefile.am: Those variables contain all enabled engines and plugins.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 771a9570950..a0d19e8271d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,11 +24,11 @@ EXTRA_DIST = INSTALL-SOURCE INSTALL-WIN-SOURCE \
SUBDIRS = . include @docs_dirs@ @zlib_dir@ \
@readline_topdir@ sql-common \
@thread_dirs@ pstack \
- @sql_union_dirs@ storage plugin \
+ @sql_union_dirs@ unittest storage plugin \
@sql_server@ scripts @man_dirs@ tests \
netware @libmysqld_dirs@ \
mysql-test support-files @tools_dirs@ \
- unittest win
+ win
DIST_SUBDIRS = $(SUBDIRS) BUILD