summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <msvensson@pilot.blaudden>2007-03-27 23:56:48 +0200
committerunknown <msvensson@pilot.blaudden>2007-03-27 23:56:48 +0200
commitc2d2ede33c4c67258676f26f7030ee3d79be5ef2 (patch)
tree02a7e0d66c1854e1350626ab89132b36162066bd /Makefile.am
parent094db7029ea92e7dc6c0731e5e6f19285f415536 (diff)
downloadmariadb-git-c2d2ede33c4c67258676f26f7030ee3d79be5ef2.tar.gz
Bug#22508 BUILD/compile-dist fails due to problem with readline/libedit
- Move the link_sources command from top level Makefile into each subdir that need to link files BitKeeper/etc/ignore: Added libmysqld/link_sources libmysql/link_sources include/link_sources client/link_sources to the ignore list Makefile.am: Move link_sources down into each sub directory that might need it client/Makefile.am: Add "link_sources" to BUILT_SOURCES configure.in: Move link_sources down into each sub directory that might need it include/Makefile.am: Add "link_sources" to BUILT_SOURCES libmysql/Makefile.am: Add "link_sources" to BUILT_SOURCES libmysql/Makefile.shared: Add "link_sources" to BUILT_SOURCES libmysqld/Makefile.am: Add "link_sources" to BUILT_SOURCES libmysqld/examples/Makefile.am: Add "link_sources" to BUILT_SOURCES netware/Makefile.am: Add "link_sources" to BUILT_SOURCES sql/Makefile.am: Add "link_sources" to BUILT_SOURCES
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am40
1 files changed, 0 insertions, 40 deletions
diff --git a/Makefile.am b/Makefile.am
index 6d435bff85a..825f77846c4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,48 +31,8 @@ SUBDIRS = . include @docs_dirs@ @zlib_dir@ \
DIST_SUBDIRS = $(SUBDIRS) BUILD
-# Run these targets before any others, also make part of clean target,
-# to make sure we create new links after a clean.
-BUILT_SOURCES = linked_client_sources linked_server_sources \
- @linked_client_targets@ \
- @linked_libmysqld_targets@ \
- linked_include_sources @linked_netware_sources@
-
-CLEANFILES = $(BUILT_SOURCES)
DISTCLEANFILES = ac_available_languages_fragment
-linked_include_sources:
- cd include; $(MAKE) link_sources
- echo timestamp > linked_include_sources
-
-linked_client_sources: @linked_client_targets@
- cd client; $(MAKE) link_sources
- echo timestamp > linked_client_sources
-
-linked_libmysql_sources:
- cd libmysql; $(MAKE) link_sources
- echo timestamp > linked_libmysql_sources
-
-linked_libmysql_r_sources: linked_libmysql_sources
- cd libmysql_r; $(MAKE) link_sources
- echo timestamp > linked_libmysql_r_sources
-
-linked_libmysqld_sources:
- cd libmysqld; $(MAKE) link_sources
- echo timestamp > linked_libmysqld_sources
-
-linked_libmysqldex_sources:
- cd libmysqld/examples; $(MAKE) link_sources
- echo timestamp > linked_libmysqldex_sources
-
-linked_netware_sources:
- cd @netware_dir@; $(MAKE) link_sources
- echo timestamp > linked_netware_sources
-
-linked_server_sources:
- cd sql; $(MAKE) link_sources
- echo timestamp > linked_server_sources
-
# Create permission databases
init-db: all
$(top_builddir)/scripts/mysql_install_db