summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorkonstantin@mysql.com <>2004-06-24 22:33:40 +0400
committerkonstantin@mysql.com <>2004-06-24 22:33:40 +0400
commita32bb3c0c40d1a5c7ace1291664152ecd6c3622a (patch)
tree6902be2d4d88408e0ad3fe46ba8f7f518f262eb9 /Makefile.am
parent54615ebcc5b498f3230dbcb543bf6de74c7cc80b (diff)
downloadmariadb-git-a32bb3c0c40d1a5c7ace1291664152ecd6c3622a.tar.gz
Fix of broken 4.1 tree:
Initially my_time.c was added to sql/ link_sources target only. As it turns out this target is sometimes not called; instead of it make calls one hard-coded in top-level Makefile.am. Now adding linking of my_time.c to the top-level Makefile.am to (hopefully) cover all cases.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6d69ea85eb2..8f702a0e865 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -71,7 +71,8 @@ linked_server_sources:
cd sql; rm -f mini_client_errors.c;\
@LN_CP_F@ ../libmysql/errmsg.c mini_client_errors.c;\
rm -f pack.c;@LN_CP_F@ ../sql-common/pack.c pack.c;\
- rm -f client.c;@LN_CP_F@ ../sql-common/client.c client.c
+ rm -f client.c;@LN_CP_F@ ../sql-common/client.c client.c\
+ rm -f my_time.c;@LN_CP_F@ ../sql-common/my_time.c my_time.c
echo timestamp > linked_server_sources
# Create permission databases