summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <tim@black.box>2001-09-16 21:41:22 -0400
committerunknown <tim@black.box>2001-09-16 21:41:22 -0400
commit5fffbb123615ad0b256652390467b33ed2919afc (patch)
tree7ff6a4243043fa71bd04fa3434bd8e13992df771 /Makefile.am
parent34925f8d823c700c939f0622b6af85001458a226 (diff)
downloadmariadb-git-5fffbb123615ad0b256652390467b33ed2919afc.tar.gz
Add some examples for using libmysqld, including a hack for running the
mysql test suite. A few minor libmysqld fixes. Add mysql_server_init() and _end() to mysql.cc and mysqltest.c, so they can be linked against libmysqlclient or libmysqld. sql/mysqld.cc: have unireg_end() exit(), instead of pthread_exit() if inside the EMBEDDED_LIBRARY. This is a hack which hopefully won't be needed. But without it, the program hangs at end. client/mysql.cc: Don't call mysql_ssl_clear() unless HAVE_OPENSSL. client/mysqltest.c: Add mysql_server_init() and _end(). acinclude.m4: change .. to $(top_builddir) in innodb_libs Makefile.am: Add libmysqld/examples to link_sources target configure.in: output libmysqld/examples/Makefile Also, change .. to $(top_builddir) in readline_link BitKeeper/etc/ignore: added linked_libmysqldex_sources mysql-test/mysql-test-run.sh: use latin1, not latin1_de, in tests libmysqld/libmysqld.c: Add replication functions.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 61ea903ddb2..8ec9b965757 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,7 +29,8 @@ SUBDIRS = include @docs_dirs@ @readline_dir@ \
# Relink after clean
linked_sources = linked_client_sources linked_server_sources \
linked_libmysql_sources linked_libmysql_r_sources \
- linked_libmysqld_sources linked_include_sources
+ linked_libmysqld_sources linked_libmysqldex_sources \
+ linked_include_sources
CLEANFILES = $(linked_sources)
@@ -56,6 +57,10 @@ linked_libmysqld_sources:
cd libmysqld; $(MAKE) link_sources
echo timestamp > linked_libmysqld_sources
+linked_libmysqldex_sources:
+ cd libmysqld/examples; $(MAKE) link_sources
+ echo timestamp > linked_libmysqldex_sources
+
#avoid recursive make calls in sql directory
linked_server_sources:
cd sql; rm -f mini_client_errors.c;@LN_CP_F@ ../libmysql/errmsg.c mini_client_errors.c