summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <knielsen@knielsen-hq.org>2009-10-02 11:40:03 +0200
committerunknown <knielsen@knielsen-hq.org>2009-10-02 11:40:03 +0200
commit0e90c848265cca7364f36eb511a4492815fc714f (patch)
treeaf7b60ca6d0e485aca64ddf93b7fc8fab6085793 /Makefile.am
parentb883abd675b51ad8af5dba2e47666ade4574bc8a (diff)
downloadmariadb-git-0e90c848265cca7364f36eb511a4492815fc714f.tar.gz
Add a simple way to robustly get the name of the generated source tarball, so as to not
to have to rely on fragile regexp-parsing of configure.in.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a2231876677..55d4794d0d5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,6 +60,11 @@ dist-hook:
--srcdir=$(top_srcdir)
storage/myisam/myisamchk --silent --fast $(distdir)/win/data/mysql/*.MYI
+# Simple target to allow scripts etc. to get the name of the source
+# tarball easily.
+show-dist-name:
+ @echo "$(PACKAGE)-$(VERSION)"
+
all-local: @ABI_CHECK@
tags: