summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <monty@donna.mysql.com>2000-09-14 15:10:06 +0300
committerunknown <monty@donna.mysql.com>2000-09-14 15:10:06 +0300
commit3dac17511b0a96ae6696eec846517596a5f73eee (patch)
tree217d8c8b9714b5bf60fec8a535b514b4598a3a12 /Makefile.am
parentd5964ba20ca4c00a443c185186def44bb90831b3 (diff)
downloadmariadb-git-3dac17511b0a96ae6696eec846517596a5f73eee.tar.gz
configure fixes
scripts/make_binary_distribution.sh: Change mode to -rw-rw-r-- scripts/mysql_convert_table_format.sh: Change mode to -rw-rw-r-- scripts/mysql_find_rows.sh: Change mode to -rw-rw-r-- scripts/mysql_setpermission.sh: Change mode to -rw-rw-r-- scripts/mysql_zap.sh: Change mode to -rw-rw-r-- scripts/mysqlaccess.sh: Change mode to -rw-rw-r-- scripts/mysqlbug.sh: Change mode to -rw-rw-r-- scripts/mysqlhotcopy.sh: Change mode to -rw-rw-r-- scripts/safe_mysqld-watch.sh: Change mode to -rw-rw-r-- scripts/safe_mysqld.sh: Change mode to -rw-rw-r-- scripts/mysqlaccess.conf: Change mode to -rw-rw-r-- support-files/binary-configure.sh: Change mode to -rw-rw-r-- Docs/Makefile.am: Remove manual.ps when doing make distclean Docs/manual.texi: Fix Makefile.am: Fix that my_config.h is properly created and removed include/Makefile.am: Fix that my_config.h is properly created and removed libmysql/Makefile.shared: Add some distclean targets scripts/Makefile.am: Add some distclean targets support-files/Makefile.am: Add some distclean targets
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a24164f0bca..bdb3502aa3d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,7 +30,11 @@ SUBDIRS = include @docs_dirs@ @readline_dir@ \
CLEANFILES = linked_client_sources linked_server_sources linked_libmysql_sources linked_libmysql_r_sources
# This is just so that the linking is done early.
-config.h: linked_client_sources linked_server_sources
+config.h: linked_client_sources linked_server_sources linked_include_sources
+
+linked_include_sources:
+ cd include; $(MAKE) link_sources
+ echo timestamp > linked_include_sources
linked_client_sources: @linked_client_targets@
echo timestamp > linked_client_sources