summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authortsmith/tim@siva.hindu.god <>2006-12-26 16:49:10 -0700
committertsmith/tim@siva.hindu.god <>2006-12-26 16:49:10 -0700
commit0cb9cee7f4b72e198e8ae4600d20d5753238f205 (patch)
treee6bcbe8baaed6b27ac43fd5aa816ebe6f1e949f8 /Makefile.am
parentbe15e3bc15921085ea558f8764ed1fad137ccaa1 (diff)
parent4d8942648bfbf894908e20074da332fff03237ed (diff)
downloadmariadb-git-0cb9cee7f4b72e198e8ae4600d20d5753238f205.tar.gz
Merge siva.hindu.god:/usr/home/tim/m/bk/g51
into siva.hindu.god:/usr/home/tim/m/bk/tmp/mrg51-dec26
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index f2b01afe5e6..df6c6ca580a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -102,8 +102,10 @@ dist-hook:
tags:
support-files/build-tags
-.PHONY: init-db bin-dist test test-full test-ps test-nr \
- test-ns test-pr test-unit
+.PHONY: init-db bin-dist \
+ test test-force test-full test-force-full test-force-mem \
+ test-pl test-force-pl test-full-pl test-force-full-pl test-force-pl-mem \
+ test-unit test-ps test-nr test-pr test-ns test-binlog-statement
# Target 'test' will run the regression test suite using the built server.
#
@@ -118,23 +120,23 @@ test-unit:
test-ps:
cd mysql-test ; \
- ./mysql-test-run.pl $(force) --ps-protocol --mysqld=--binlog-format=mixed
+ @PERL@ ./mysql-test-run.pl $(force) --ps-protocol --mysqld=--binlog-format=mixed
test-nr:
cd mysql-test ; \
- ./mysql-test-run.pl $(force) --mysqld=--binlog-format=row
+ @PERL@ ./mysql-test-run.pl $(force) --mysqld=--binlog-format=row
test-pr:
cd mysql-test ; \
- ./mysql-test-run.pl $(force) --ps-protocol --mysqld=--binlog-format=row
+ @PERL@ ./mysql-test-run.pl $(force) --ps-protocol --mysqld=--binlog-format=row
test-ns:
cd mysql-test ; \
- ./mysql-test-run.pl $(force) --mysqld=--binlog-format=mixed
+ @PERL@ ./mysql-test-run.pl $(force) --mysqld=--binlog-format=mixed
test-binlog-statement:
cd mysql-test ; \
- ./mysql-test-run.pl $(force) --mysqld=--binlog-format=statement
+ @PERL@ ./mysql-test-run.pl $(force) --mysqld=--binlog-format=statement
test: test-unit test-ns test-pr