summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorkonstantin@mysql.com <>2004-07-24 03:30:11 -0700
committerkonstantin@mysql.com <>2004-07-24 03:30:11 -0700
commit569d3c848884b09f30ec0e8ef8bafb73aa167e3e (patch)
tree35c5c62bc54e061c8e7e29c5b464024e78b3408d /Makefile.am
parentcd5ed13e4d32b55ab4ddad6a8f6d7ab082504dd8 (diff)
downloadmariadb-git-569d3c848884b09f30ec0e8ef8bafb73aa167e3e.tar.gz
WL#1518, "make bundled zlib usable for unix builds":
required autotools macro written and deployed in all apropriate Makefile.ams. Use cases checked: - linux, standard location of zlib, no ndb - linux, standard locatoin of zlib, with ndb - linux, non-standard location of zlib, no ndb - hpux11, use of bundled zlib, no ndb The only non-checked case is non-standard location of zlib (or use of bundled zlib) + ndb. I wasn't able to check it as ndb/ just won't compile on beasts like AIX52 or HPUX11, where such a check is possible. It didn't compile there before as these systems dont't have installed zlib, so nothing got broken ;)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f8efb247c95..e2d61e56b60 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,8 +19,15 @@
AUTOMAKE_OPTIONS = foreign
# These are built from source in the Docs directory
-EXTRA_DIST = INSTALL-SOURCE README COPYING zlib
-SUBDIRS = . include @docs_dirs@ \
+EXTRA_DIST = INSTALL-SOURCE README COPYING
+SUBDIRS = . include @docs_dirs@ @zlib_dir@ \
+ @readline_topdir@ sql-common \
+ @thread_dirs@ pstack @sql_client_dirs@ \
+ @sql_server_dirs@ scripts man tests \
+ netware @libmysqld_dirs@ \
+ @bench_dirs@ support-files @fs_dirs@ @tools_dirs@
+
+DIST_SUBDIRS = . include @docs_dirs@ zlib \
@readline_topdir@ sql-common \
@thread_dirs@ pstack @sql_client_dirs@ \
@sql_server_dirs@ scripts man tests SSL\