summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorVladislav Vaintroub <vvaintroub@mysql.com>2010-03-09 22:51:36 +0100
committerVladislav Vaintroub <vvaintroub@mysql.com>2010-03-09 22:51:36 +0100
commite8d4f1f2fa855b6da75814d59fdb648e661126fe (patch)
tree1664c501d36528dd76529fe5805c6c28b82e8cb5 /Makefile.am
parent1b0d2eefb74d3ec5d71979a670884d511ca678cf (diff)
downloadmariadb-git-e8d4f1f2fa855b6da75814d59fdb648e661126fe.tar.gz
Bug#51607: Automake distcheck target broken.
Reason for the error was that ./configure wrapper script was not safe for VPATH builds used by "make distcheck", specifically it expected configure.am to be in the current directory. Fix changes configure wrapper to resolve script names relative to configure script path. Also, use $top_srcdir/configure.am instead of configure.am in dist-hook to be more VPATH friendly.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f64b26602d7..fbb7605493e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,7 +60,8 @@ dist-hook:
--datadir=$(distdir)/win/data \
--srcdir=$(top_srcdir)
storage/myisam/myisamchk --silent --fast $(distdir)/win/data/mysql/*.MYI
- test ! -f configure.am || $(INSTALL_DATA) configure.am $(distdir)
+ test ! -f $(top_srcdir)/configure.am || \
+ $(INSTALL_DATA) $(top_srcdir)/configure.am $(distdir)
all-local: @ABI_CHECK@