summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorkent@mysql.com <>2005-08-28 19:46:56 +0200
committerkent@mysql.com <>2005-08-28 19:46:56 +0200
commite2954b29a12f071023c2a75190bad8ba9f980298 (patch)
tree5dc6119d75aec556ef08efab31b1a790dcbf9c01 /Makefile.am
parentfe977b0cd0f2cbabd0a3804cfd83a02698601ad7 (diff)
downloadmariadb-git-e2954b29a12f071023c2a75190bad8ba9f980298.tar.gz
Makefile.am:
Make ports configurable from environment for test
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 1609b5a1da1..be2d34f8db8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -85,8 +85,15 @@ tags:
support-files/build-tags
.PHONY: init-db bin-dist
-# Test installation
+# Test installation. Ports are configurable from the environment.
-test:
- cd mysql-test ; ./mysql-test-run
+MYSQL_TEST_MANAGER_PORT = 9305
+MYSQL_TEST_MASTER_PORT = 9306
+MYSQL_TEST_SLAVE_PORT = 9308
+test:
+ cd mysql-test ; \
+ ./mysql-test-run \
+ --manager-port=$(MYSQL_TEST_MANAGER_PORT) \
+ --master_port=$(MYSQL_TEST_MASTER_PORT) \
+ --slave_port=$(MYSQL_TEST_SLAVE_PORT)