summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com>2005-09-29 19:37:03 +0200
committerunknown <kent@mysql.com>2005-09-29 19:37:03 +0200
commit4ed46633fc4764dbe5007805293143a92ed9c83a (patch)
tree63e9b3c73700eaf4a957b9689e02185d08ac8de9 /Makefile.am
parentb262e64316cd278bdebe830118fcc5c3d56254b6 (diff)
downloadmariadb-git-4ed46633fc4764dbe5007805293143a92ed9c83a.tar.gz
portability.h:
Corrected OpenServer ifdef test Makefile.am: Added test-pl and test-force-pl targets Makefile.am: Added test-pl and test-force-pl targets server-tools/instance-manager/portability.h: Corrected OpenServer ifdef test
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am32
1 files changed, 19 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index 3be3ce80b71..403a4ba2137 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -107,20 +107,26 @@ MYSQL_TEST_RUN_ARGS = --manager-port=$(MYSQL_TEST_MANAGER_PORT) \
--master_port=$(MYSQL_TEST_MASTER_PORT) \
--slave_port=$(MYSQL_TEST_SLAVE_PORT) \
--ndbcluster_port=$(MYSQL_TEST_NDB_PORT)
+
test:
cd mysql-test ; \
- ./mysql-test-run \
- --manager-port=$(MYSQL_TEST_MANAGER_PORT) \
- --master_port=$(MYSQL_TEST_MASTER_PORT) \
- --slave_port=$(MYSQL_TEST_SLAVE_PORT) \
- --ndbcluster_port=$(MYSQL_TEST_NDB_PORT) && \
- ./mysql-test-run --ps-protocol \
- --manager-port=$(MYSQL_TEST_MANAGER_PORT) \
- --master_port=$(MYSQL_TEST_MASTER_PORT) \
- --slave_port=$(MYSQL_TEST_SLAVE_PORT) \
- --ndbcluster_port=$(MYSQL_TEST_NDB_PORT)
+ ./mysql-test-run $(MYSQL_TEST_RUN_ARGS) && \
+ ./mysql-test-run $(MYSQL_TEST_RUN_ARGS) --ps-protocol
test-force:
- cd mysql-test; \
- ./mysql-test-run --force ;\
- ./mysql-test-run --ps-protocol --force
+ cd mysql-test ; \
+ ./mysql-test-run $(MYSQL_TEST_RUN_ARGS) --force ; \
+ ./mysql-test-run $(MYSQL_TEST_RUN_ARGS) --ps-protocol --force
+
+test-pl:
+ cd mysql-test ; \
+ ./mysql-test-run.pl $(MYSQL_TEST_RUN_ARGS) && \
+ ./mysql-test-run.pl $(MYSQL_TEST_RUN_ARGS) --ps-protocol
+
+test-force-pl:
+ cd mysql-test ; \
+ ./mysql-test-run.pl $(MYSQL_TEST_RUN_ARGS) --force ; \
+ ./mysql-test-run.pl $(MYSQL_TEST_RUN_ARGS) --ps-protocol --force
+
+# Don't update the files from bitkeeper
+%::SCCS/s.%