summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorkent@mysql.com <>2005-10-25 02:36:51 +0200
committerkent@mysql.com <>2005-10-25 02:36:51 +0200
commit6a5a451cfb9a89fb782a065a4c043d2f2ddf48db (patch)
tree96bc0c6bed74fd5068a74e8d91dd895c95282b69 /Makefile.am
parent3e653fb922ca6a9b4233cd1d8625031e851d33c5 (diff)
parent257b17ba2f9cf3d227365e59875f4162b015b3fb (diff)
downloadmariadb-git-6a5a451cfb9a89fb782a065a4c043d2f2ddf48db.tar.gz
Merge mysql.com:/Users/kent/mysql/bk/mysql-4.0-build-thread
into mysql.com:/Users/kent/mysql/bk/mysql-4.1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 10 insertions, 17 deletions
diff --git a/Makefile.am b/Makefile.am
index 9025251ff2a..eada6e08c50 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -97,29 +97,22 @@ tags:
support-files/build-tags
.PHONY: init-db bin-dist
-# Test installation. Ports are configurable from the environment.
-
-MYSQL_TEST_MANAGER_PORT = 9305
-MYSQL_TEST_MASTER_PORT = 9306
-MYSQL_TEST_SLAVE_PORT = 9308
-MYSQL_TEST_NDB_PORT = 9350
+# Target 'test' will run the regression test suite using the built server.
+#
+# If you are running in a shared environment, users can avoid clashing
+# port numbers by setting individual small numbers 1-100 to the
+# environment variable MTR_BUILD_THREAD. The script "mysql-test-run"
+# will then calculate the various port numbers it needs from this,
+# making sure each user use different ports.
test:
cd mysql-test ; \
- ./mysql-test-run \
- --manager-port=$(MYSQL_TEST_MANAGER_PORT) \
- --master_port=$(MYSQL_TEST_MASTER_PORT) \
- --slave_port=$(MYSQL_TEST_SLAVE_PORT) \
- --ndbcluster_port=$(MYSQL_TEST_NDB_PORT) && \
- ./mysql-test-run --ps-protocol \
- --manager-port=$(MYSQL_TEST_MANAGER_PORT) \
- --master_port=$(MYSQL_TEST_MASTER_PORT) \
- --slave_port=$(MYSQL_TEST_SLAVE_PORT) \
- --ndbcluster_port=$(MYSQL_TEST_NDB_PORT)
+ ./mysql-test-run && \
+ ./mysql-test-run --ps-protocol
test-force:
cd mysql-test; \
- ./mysql-test-run --force ;\
+ ./mysql-test-run --force ; \
./mysql-test-run --ps-protocol --force
# We are testing a new Perl version of the test script