summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias Leich mleich@mysql.com <Unknown>2008-06-02 21:57:11 +0200
committerMatthias Leich mleich@mysql.com <Unknown>2008-06-02 21:57:11 +0200
commit15440264430b8dd7c10d950926a34f8f20f14427 (patch)
treeaa83fd798596f98659faca7e6b3068a428e6216f /Makefile.am
parent200a93632edd7b9588588526c7803aa361e6cf69 (diff)
downloadmariadb-git-15440264430b8dd7c10d950926a34f8f20f14427.tar.gz
Bug#36788 Multiple funcs_1 'trig' tests are failing on vanilla builds
Fix for this bug and additional improvements/fixes In detail: - Remove unicode attribute from several columns (unicode properties were nowhere needed/tested) of the table tb3 -> The runnability of these tests depends no more on the availibility of some optional collations. - Use a table tb3 with the same layout for all engines to be tested and unify the engine name within the protocols. -> <engine>_trig_<abc>.result have the same content - Do not load data into tb3 if these rows have no impact on result sets - Add tests for NDB (they exist already in 5.1) - "--replace_result" at various places because NDB variants of tests failed with "random" row order in results This fixes a till now unknown weakness within the funcs_1 NDB tests existing in 5.1 and 6.0 - Fix the expected result of ndb_trig_1011ext which suffered from Bug 32656 + disable this test - funcs_1 could be executed with the mysql-test-run.pl option "--reorder", which saves some runtime by optimizing server restarts. Runtimes on tmpfs (one attempt only): with reorder 132 seconds without reorder 183 seconds - Adjust two "check" statements within func_misc.test which were incorrect (We had one run with result set difference though the server worked good.) - minor fixes in comments
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index eb837b1fdd4..774239eaad2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -154,7 +154,7 @@ test-bt:
-cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --force --comment=ps --ps-protocol
-cd mysql-test ; MTR_BUILD_THREAD=auto \
- @PERL@ ./mysql-test-run.pl --force --comment=funcs1_ps --ps-protocol --suite=funcs_1
+ @PERL@ ./mysql-test-run.pl --force --comment=funcs1_ps --ps-protocol --reorder --suite=funcs_1
-cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --force --comment=funcs2 --suite=funcs_2
-if [ -d mysql-test/suite/nist ] ; then \
@@ -179,7 +179,7 @@ test-force-full-pl: test-force-full
test-ext-funcs:
cd mysql-test ; \
- @PERL@ ./mysql-test-run.pl --force --suite=funcs_1 ; \
+ @PERL@ ./mysql-test-run.pl --force --reorder --suite=funcs_1 ; \
@PERL@ ./mysql-test-run.pl --force --suite=funcs_2
test-ext: test-ext-funcs