summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarc Alff <marc.alff@sun.com>2009-11-30 17:49:15 -0700
committerMarc Alff <marc.alff@sun.com>2009-11-30 17:49:15 -0700
commitfa3cfa07ddda7c1d17a2eacc8acfb1f87f625ff9 (patch)
tree60c7ded488b2fdc27e6b1d0de6f621cf4503e7dd /Makefile.am
parent4b28a6ce84fbcab3e819018a03c116c0939dab5e (diff)
downloadmariadb-git-fa3cfa07ddda7c1d17a2eacc8acfb1f87f625ff9.tar.gz
WL#2360 Performance schema
Part 1: Instrumentation interface
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index c208b5b6df1..fd55ec099fa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -269,11 +269,12 @@ test-full-qa:
#
API_PREPROCESSOR_HEADER = $(top_srcdir)/include/mysql/plugin.h \
- $(top_srcdir)/include/mysql.h
+ $(top_srcdir)/include/mysql.h \
+ $(top_srcdir)/include/mysql/psi/psi_abi_v1.h \
+ $(top_srcdir)/include/mysql/psi/psi_abi_v2.h
-TEST_PREPROCESSOR_HEADER = $(top_srcdir)/include/mysql/plugin.h \
- $(top_srcdir)/sql/mysql_priv.h \
- $(top_srcdir)/include/mysql.h
+TEST_PREPROCESSOR_HEADER = $(API_PREPROCESSOR_HEADER) \
+ $(top_srcdir)/sql/mysql_priv.h
#
# Rules for checking that the abi/api has not changed.