summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <cmiller@zippy.cornsilk.net>2007-01-07 09:31:49 -0500
committerunknown <cmiller@zippy.cornsilk.net>2007-01-07 09:31:49 -0500
commit0517aa59ed854e0fce173a169fb3f07b36fbe201 (patch)
treeef218d11fc7a48e2a033e23e5e9cbe9dfda3a7ed /Makefile.am
parent702a25ddb86c3231bee2a97fae5ddb14067540c2 (diff)
parentead6b1055767c1f590e66ef8e42ac4b5796ef421 (diff)
downloadmariadb-git-0517aa59ed854e0fce173a169fb3f07b36fbe201.tar.gz
Merge bk-internal.mysql.com:/home/bk/mysql-5.1
into zippy.cornsilk.net:/home/cmiller/work/mysql/mysql-5.1-maint-greener Makefile.am: Auto merged configure.in: Auto merged include/mysql.h: Auto merged mysql-test/Makefile.am: Auto merged mysql-test/lib/mtr_cases.pl: Auto merged mysql-test/lib/mtr_process.pl: Auto merged mysql-test/mysql-test-run.pl: Auto merged mysql-test/r/myisam.result: Auto merged mysql-test/r/view.result: Auto merged mysql-test/t/myisam.test: Auto merged scripts/make_binary_distribution.sh: Auto merged scripts/mysqlbug.sh: Auto merged server-tools/instance-manager/Makefile.am: Auto merged sql/event_queue.cc: Auto merged sql/field.cc: Auto merged sql/field.h: Auto merged sql/item_sum.h: Auto merged sql/opt_range.cc: Auto merged sql/sql_class.h: Auto merged sql/sql_parse.cc: Auto merged sql/sql_plugin.cc: Auto merged sql/sql_show.cc: Auto merged storage/federated/ha_federated.cc: Auto merged mysql-test/r/warnings.result: Manual merge. mysql-test/t/warnings.test: Manual merge. strings/ctype-extra.c: Manual merge.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 7c80ea24326..21d070a3416 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -102,8 +102,10 @@ dist-hook:
tags:
support-files/build-tags
-.PHONY: init-db bin-dist test test-full test-ps test-nr \
- test-ns test-pr test-unit
+.PHONY: init-db bin-dist \
+ test test-force test-full test-force-full test-force-mem \
+ test-pl test-force-pl test-full-pl test-force-full-pl test-force-pl-mem \
+ test-unit test-ps test-nr test-pr test-ns test-binlog-statement
# Target 'test' will run the regression test suite using the built server.
#
@@ -118,23 +120,23 @@ test-unit:
test-ps:
cd mysql-test ; \
- ./mysql-test-run.pl $(force) --ps-protocol --mysqld=--binlog-format=mixed
+ @PERL@ ./mysql-test-run.pl $(force) --ps-protocol --mysqld=--binlog-format=mixed
test-nr:
cd mysql-test ; \
- ./mysql-test-run.pl $(force) --mysqld=--binlog-format=row
+ @PERL@ ./mysql-test-run.pl $(force) --mysqld=--binlog-format=row
test-pr:
cd mysql-test ; \
- ./mysql-test-run.pl $(force) --ps-protocol --mysqld=--binlog-format=row
+ @PERL@ ./mysql-test-run.pl $(force) --ps-protocol --mysqld=--binlog-format=row
test-ns:
cd mysql-test ; \
- ./mysql-test-run.pl $(force) --mysqld=--binlog-format=mixed
+ @PERL@ ./mysql-test-run.pl $(force) --mysqld=--binlog-format=mixed
test-binlog-statement:
cd mysql-test ; \
- ./mysql-test-run.pl $(force) --mysqld=--binlog-format=statement
+ @PERL@ ./mysql-test-run.pl $(force) --mysqld=--binlog-format=statement
test: test-unit test-ns test-pr