summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com>2005-09-24 02:43:28 +0200
committerunknown <kent@mysql.com>2005-09-24 02:43:28 +0200
commitb337566babce87b4a5854f18586206525a4ba1b7 (patch)
tree644c1e8893f0f817d64eec1618ca175ef1bfd198 /Makefile.am
parenta51f78320e1e49f1d0bf8508d8779042f95ac0c8 (diff)
parent3614cff71cc79b197863a968d385cb2cce1680fd (diff)
downloadmariadb-git-b337566babce87b4a5854f18586206525a4ba1b7.tar.gz
Merge kboortz@bk-internal.mysql.com:/home/bk/mysql-4.1
into mysql.com:/Users/kent/mysql/bk/mysql-4.1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ae0d56ba9fd..9025251ff2a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -106,12 +106,12 @@ MYSQL_TEST_NDB_PORT = 9350
test:
cd mysql-test ; \
- ./mysql-test-run.pl \
+ ./mysql-test-run \
--manager-port=$(MYSQL_TEST_MANAGER_PORT) \
--master_port=$(MYSQL_TEST_MASTER_PORT) \
--slave_port=$(MYSQL_TEST_SLAVE_PORT) \
--ndbcluster_port=$(MYSQL_TEST_NDB_PORT) && \
- ./mysql-test-run.pl --ps-protocol \
+ ./mysql-test-run --ps-protocol \
--manager-port=$(MYSQL_TEST_MANAGER_PORT) \
--master_port=$(MYSQL_TEST_MASTER_PORT) \
--slave_port=$(MYSQL_TEST_SLAVE_PORT) \
@@ -121,3 +121,14 @@ test-force:
cd mysql-test; \
./mysql-test-run --force ;\
./mysql-test-run --ps-protocol --force
+
+# We are testing a new Perl version of the test script
+test-pl:
+ cd mysql-test; \
+ ./mysql-test-run.pl && \
+ ./mysql-test-run.pl --ps-protocol
+
+test-force-pl:
+ cd mysql-test; \
+ ./mysql-test-run.pl --force ; \
+ ./mysql-test-run.pl --ps-protocol --force