summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com>2005-08-28 20:21:47 +0200
committerunknown <kent@mysql.com>2005-08-28 20:21:47 +0200
commit11d32b4af305ba98f19d24adc65a04816bfb2861 (patch)
tree7c962abeabf199dce8e954a9e32e876042e153c7 /Makefile.am
parentf02d34ddc9b0c4a744ae8214c7570bc61b392a58 (diff)
parent8dd3a7d9a7cc9320478774ae8be0e66dfc73acb0 (diff)
downloadmariadb-git-11d32b4af305ba98f19d24adc65a04816bfb2861.tar.gz
Merge mysql.com:/Users/kent/mysql/bk/mysql-4.1
into mysql.com:/Users/kent/mysql/bk/mysql-5.0
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 18 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 6eb7421880e..353a05eeb14 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -103,10 +103,25 @@ test:
cd mysql-test; \
./mysql-test-run && ./mysql-test-run --ps-protocol
+# Test installation. Ports are configurable from the environment.
+
+MYSQL_TEST_MANAGER_PORT = 9305
+MYSQL_TEST_MASTER_PORT = 9306
+MYSQL_TEST_SLAVE_PORT = 9308
+MYSQL_TEST_NDB_PORT = 9350
+MYSQL_TEST_RUN_ARGS = --manager-port=$(MYSQL_TEST_MANAGER_PORT) \
+ --master_port=$(MYSQL_TEST_MASTER_PORT) \
+ --slave_port=$(MYSQL_TEST_SLAVE_PORT) \
+ --ndbcluster_port=$(MYSQL_TEST_NDB_PORT)
+test:
+ cd mysql-test ; \
+ ./mysql-test-run.pl $(MYSQL_TEST_RUN_ARGS) && \
+ ./mysql-test-run.pl --ps-protocol $(MYSQL_TEST_RUN_ARGS)
+
test-force:
- cd mysql-test; \
- ./mysql-test-run --force ;\
- ./mysql-test-run --ps-protocol --force
+ cd mysql-test ; \
+ ./mysql-test-run --force $(MYSQL_TEST_RUN_ARGS) ; \
+ ./mysql-test-run --ps-protocol --force $(MYSQL_TEST_RUN_ARGS)
# Don't update the files from bitkeeper
%::SCCS/s.%