summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <aelkin/elkin@dsl-hkigw8-feaaf900-177.dhcp.inet.fi>2006-08-30 21:43:05 +0300
committerunknown <aelkin/elkin@dsl-hkigw8-feaaf900-177.dhcp.inet.fi>2006-08-30 21:43:05 +0300
commit4da5da9d7cb71c8693514832970d4b03045eaf4e (patch)
treec53cd64d7476a5b1191cabbf50a2814267a61b88 /Makefile.am
parent86148b90e2edbfd7f27c44c4e75940eb652ac31f (diff)
downloadmariadb-git-4da5da9d7cb71c8693514832970d4b03045eaf4e.tar.gz
WL#3368 mixed format as default
Two minor fixes: 1. to make make test executes with mixed; 2. proper isolation of binlog_statement_insert_delayed from others through reset master cleaning up binlog todo: adapt this technique to other restarting for binlog tests Makefile.am: Binlog format switches to MIXED. A new Makefile target test-binlog-statement is introduced for checking tests requiring exclusive STATEMENT format. mysql-test/t/binlog_statement_insert_delayed.test: cheapest method to clean up binlog after previous tests
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8a575b3c365..bcffe546e7e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -118,7 +118,7 @@ test-unit:
test-ps:
cd mysql-test ; \
- ./mysql-test-run.pl $(force) --ps-protocol --mysqld=--binlog-format=statement
+ ./mysql-test-run.pl $(force) --ps-protocol --mysqld=--binlog-format=mixed
test-nr:
cd mysql-test ; \
@@ -130,6 +130,10 @@ test-pr:
test-ns:
cd mysql-test ; \
+ ./mysql-test-run.pl $(force) --mysqld=--binlog-format=mixed
+
+test-binlog-statement:
+ cd mysql-test ; \
./mysql-test-run.pl $(force) --mysqld=--binlog-format=statement
test: test-unit test-ns test-pr