summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authordavi@skynet.(none) <>2008-05-19 13:39:31 -0300
committerdavi@skynet.(none) <>2008-05-19 13:39:31 -0300
commit2f770c91d21c6fc58f29f55782ce22472bba05bc (patch)
treef317faf48c7a017f96d86a6d506eb988d7dbe755 /Makefile.am
parentaef39682d656314a5f3aab7998e4159e88520e79 (diff)
downloadmariadb-git-2f770c91d21c6fc58f29f55782ce22472bba05bc.tar.gz
Bug#27430 Crash in subquery code when in PS and table DDL changed after PREPARE
Add test target to the makefile that will cause all statements to be re-prepared before execution.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ad94c9ea325..5cf4fa9ba49 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,7 +66,7 @@ tags:
test-pl test-force-pl test-full-pl test-force-full-pl test-force-pl-mem \
test-unit test-ps test-nr test-pr test-ns test-binlog-statement \
test-ext-funcs test-ext-rpl test-ext-partitions test-ext-jp \
- test-ext-stress test-ext test-embedded \
+ test-ext-stress test-ext test-embedded test-reprepare \
test-fast test-fast-cursor test-fast-view test-fast-prepare \
test-full-qa
@@ -111,6 +111,11 @@ test-embedded:
echo "no program found for 'embedded' tests - skipped testing" ; \
fi
+test-reprepare:
+ cd mysql-test ; \
+ @PERL@ ./mysql-test-run.pl $(force) $(mem) --ps-protocol \
+ --mysqld=--debug=+d,reprepare_each_statement
+
test: test-unit test-ns test-pr
test-full: test test-nr test-ps