summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <joerg@trift2.>2007-06-22 20:08:19 +0200
committerunknown <joerg@trift2.>2007-06-22 20:08:19 +0200
commit054201f48d765116a0a478166441c41f6f0bf5f5 (patch)
tree83e1326673cda137641d961b8b070b2a685fc4a2 /Makefile.am
parentbdc321396371b38f0521b1b4b0ab6c3858c0a6e9 (diff)
downloadmariadb-git-054201f48d765116a0a478166441c41f6f0bf5f5.tar.gz
Add the "nist" suite to the "test-bt" target,
to be run only if it is available on the machine.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6cb080aed5a..186a3ec2453 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -159,6 +159,14 @@ test-bt:
@PERL@ ./mysql-test-run.pl --force --comment=funcs2 --suite=funcs_2
-cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --force --comment=rowlock --suite=row_lock
+ -if [ -d mysql-test/suite/nist ] ; then \
+ cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --comment=NIST+normal --force --suite=nist ; \
+ fi
+ -if [ -d mysql-test/suite/nist ] ; then \
+ cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --comment=NIST+ps --force --suite=nist --ps-protocol ; \
+ fi
test-bt-debug:
-cd mysql-test ; MTR_BUILD_THREAD=auto \