summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authortsmith/tim@siva.hindu.god <>2006-12-08 16:26:41 -0700
committertsmith/tim@siva.hindu.god <>2006-12-08 16:26:41 -0700
commitd54c696c24b28975d85893d51270bd33e64a0e83 (patch)
tree94d0f66b1f0922ba8f7a818677628844da90bbfa /Makefile.am
parent6d1e7bcf7bcdf53985117651bc198965ceec3e25 (diff)
parenta58d08513bc814fc2513a4d5c0ab6f7b3c82264b (diff)
downloadmariadb-git-d54c696c24b28975d85893d51270bd33e64a0e83.tar.gz
Merge siva.hindu.god:/usr/home/tim/m/bk/tmp/fix-Makefile-perl/41
into siva.hindu.god:/usr/home/tim/m/bk/tmp/fix-Makefile-perl/50
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am40
1 files changed, 28 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 81ff4cf5a86..f7a9ffa7c2a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -109,7 +109,11 @@ dist-hook:
tags:
support-files/build-tags
-.PHONY: init-db bin-dist
+
+.PHONY: init-db bin-dist \
+ test test-force test-full test-force-full test-force-mem \
+ test-pl test-force-pl test-full-pl test-force-full-pl test-force-pl-mem \
+ test-ps test-ns
# Target 'test' will run the regression test suite using the built server.
#
@@ -119,21 +123,33 @@ tags:
# will then calculate the various port numbers it needs from this,
# making sure each user use different ports.
-test:
+test-ps:
+ cd mysql-test ; \
+ @PERL@ ./mysql-test-run.pl $(force) --ps-protocol
+
+test-ns:
cd mysql-test ; \
- ./mysql-test-run && \
- ./mysql-test-run --ps-protocol
+ @PERL@ ./mysql-test-run.pl $(force)
+
+test: test-ns test-ps
+
+# To ease script-writing, although in 5.0 it is identical to 'test'
+test-full: test
test-force:
- cd mysql-test; \
- ./mysql-test-run --force && \
- ./mysql-test-run --ps-protocol --force
+ $(MAKE) force=--force test
-test-force-mem:
- cd mysql-test; \
- ./mysql-test-run --force --mem && \
- ./mysql-test-run --ps-protocol --force --mem
+test-force-full:
+ $(MAKE) force=--force test-full
#used by autopush.pl to run memory based tests
-
+test-force-mem:
+ $(MAKE) 'force=--force --mem' test
+
+# Keep these for a while
+test-pl: test
+test-full-pl: test-full
+test-force-pl: test-force
+test-force-pl-mem: test-force-mem
+test-force-full-pl: test-force-full