summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNarayanan V <v.narayanan@sun.com>2008-08-08 14:30:05 +0530
committerNarayanan V <v.narayanan@sun.com>2008-08-08 14:30:05 +0530
commitbd441c4d60e0a31086eab82ea7eb5efe86ca8ece (patch)
tree30fcd939d206cb1727deb6c43b23c0ca545afd65 /Makefile.am
parent3236c07b7f75473bc46da8a526ca9300c6d0b894 (diff)
downloadmariadb-git-bd441c4d60e0a31086eab82ea7eb5efe86ca8ece.tar.gz
WL#4380
1) Disabled abi_check rule for all compilers except gcc 2) restored the -dI option to retain the header information. Makefile.am: 1) changed all-local to depend on a configure variable that will be set based on if the compiler is gcc. 2) restored the -dI option removed earlier since now only gcc is being used. configure.in: Added a check to see if gcc is being used. If it is being used set the ABI_CHECK variable to the abi_check target. include/mysql.h.pp: The .pp file is changed to correspond to the option -dI.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 409504bddff..91509f68ccc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -58,7 +58,7 @@ dist-hook:
--datadir=$(distdir)/win/data \
--srcdir=$(top_srcdir)
-all-local: abi_check
+all-local: @ABI_CHECK@
tags:
support-files/build-tags
@@ -292,7 +292,7 @@ abi_check_all: $(TEST_PREPROCESSOR_HEADER)
do_abi_check:
set -ex; \
for file in $(abi_headers); do \
- @CC@ -E -nostdinc \
+ @CC@ -E -nostdinc -dI \
-I$(top_srcdir)/include \
-I$(top_srcdir)/include/mysql \
-I$(top_srcdir)/sql \