summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com>2005-10-25 02:36:51 +0200
committerunknown <kent@mysql.com>2005-10-25 02:36:51 +0200
commit133ea93bc4868f2666fb33f12c1dde54556c1023 (patch)
tree96bc0c6bed74fd5068a74e8d91dd895c95282b69 /Makefile.am
parent8d6634c9e0c43b2d4ed2b0cc9f90b66c850855ab (diff)
parente17b176e9b9a2589a54e972bdede1138937317cc (diff)
downloadmariadb-git-133ea93bc4868f2666fb33f12c1dde54556c1023.tar.gz
Merge mysql.com:/Users/kent/mysql/bk/mysql-4.0-build-thread
into mysql.com:/Users/kent/mysql/bk/mysql-4.1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 10 insertions, 17 deletions
diff --git a/Makefile.am b/Makefile.am
index 9025251ff2a..eada6e08c50 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -97,29 +97,22 @@ tags:
support-files/build-tags
.PHONY: init-db bin-dist
-# Test installation. Ports are configurable from the environment.
-
-MYSQL_TEST_MANAGER_PORT = 9305
-MYSQL_TEST_MASTER_PORT = 9306
-MYSQL_TEST_SLAVE_PORT = 9308
-MYSQL_TEST_NDB_PORT = 9350
+# Target 'test' will run the regression test suite using the built server.
+#
+# If you are running in a shared environment, users can avoid clashing
+# port numbers by setting individual small numbers 1-100 to the
+# environment variable MTR_BUILD_THREAD. The script "mysql-test-run"
+# will then calculate the various port numbers it needs from this,
+# making sure each user use different ports.
test:
cd mysql-test ; \
- ./mysql-test-run \
- --manager-port=$(MYSQL_TEST_MANAGER_PORT) \
- --master_port=$(MYSQL_TEST_MASTER_PORT) \
- --slave_port=$(MYSQL_TEST_SLAVE_PORT) \
- --ndbcluster_port=$(MYSQL_TEST_NDB_PORT) && \
- ./mysql-test-run --ps-protocol \
- --manager-port=$(MYSQL_TEST_MANAGER_PORT) \
- --master_port=$(MYSQL_TEST_MASTER_PORT) \
- --slave_port=$(MYSQL_TEST_SLAVE_PORT) \
- --ndbcluster_port=$(MYSQL_TEST_NDB_PORT)
+ ./mysql-test-run && \
+ ./mysql-test-run --ps-protocol
test-force:
cd mysql-test; \
- ./mysql-test-run --force ;\
+ ./mysql-test-run --force ; \
./mysql-test-run --ps-protocol --force
# We are testing a new Perl version of the test script