summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <omer@linux.site>2007-03-16 09:21:25 -0700
committerunknown <omer@linux.site>2007-03-16 09:21:25 -0700
commitd9dcc57e5cb58886a0d3671016db64a955b9445f (patch)
tree9aef236a86311ae7959ccc4ca0ebb2bd790f6d3b /Makefile.am
parent591422d7d98cf855b0101cb8f7ed1c87cac3338f (diff)
downloadmariadb-git-d9dcc57e5cb58886a0d3671016db64a955b9445f.tar.gz
Modifications to Makefile.am to include new test options
- for including qa developed suites - for options to run 'fast' tests Makefile.am: Modifications to include new test options - for including qa developed suites - for options to run 'fast' tests
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am49
1 files changed, 45 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 6d435bff85a..1aa6c48755f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -97,7 +97,10 @@ tags:
.PHONY: init-db bin-dist \
test test-force test-full test-force-full test-force-mem \
test-pl test-force-pl test-full-pl test-force-full-pl test-force-pl-mem \
- test-unit test-ps test-nr test-pr test-ns test-binlog-statement
+ test-unit test-ps test-nr test-pr test-ns test-binlog-statement \
+ test-ext-funcs test-ext-rpl test-ext-partitions test-ext \
+ test-fast test-fast-cursor test-fast-view test-fast-prepare \
+ test-full-qa
# Target 'test' will run the regression test suite using the built server.
#
@@ -120,11 +123,11 @@ test-nr:
test-pr:
cd mysql-test ; \
- @PERL@ ./mysql-test-run.pl $(force) --ps-protocol --mysqld=--binlog-format=row
+ @PERL@ ./mysql-test-run.pl $(force) $(mem) --ps-protocol --mysqld=--binlog-format=row
test-ns:
cd mysql-test ; \
- @PERL@ ./mysql-test-run.pl $(force) --mysqld=--binlog-format=mixed
+ @PERL@ ./mysql-test-run.pl $(force) $(mem) --mysqld=--binlog-format=mixed
test-binlog-statement:
cd mysql-test ; \
@@ -142,7 +145,7 @@ test-force-full:
#used by autopush.pl to run memory based tests
test-force-mem:
- $(MAKE) 'force=--force --mem' test
+ $(MAKE) force=--force mem=--mem test
# Keep these for a while
test-pl: test
@@ -151,5 +154,43 @@ test-force-pl: test-force
test-force-pl-mem: test-force-mem
test-force-full-pl: test-force-full
+test-ext-funcs:
+ cd mysql-test ; \
+ @PERL@ ./mysql-test-run.pl --force --suite=funcs_1 ; \
+ @PERL@ ./mysql-test-run.pl --force --suite=funcs_2
+
+test-ext-rpl:
+ cd mysql-test ; \
+ @PERL@ ./mysql-test-run.pl --force --suite=rpl
+
+test-ext-partitions:
+ cd mysql-test ; \
+ @PERL@ ./mysql-test-run.pl --force --suite=partitions
+
+test-ext-jp:
+ cd mysql-test ; \
+ @PERL@ ./mysql-test-run.pl --force --suite=jp
+
+test-ext: test-ext-funcs test-ext-rpl test-ext-partitions test-ext-jp
+
+test-fast:
+ cd mysql-test ; \
+ @PERL@ ./mysql-test-run.pl $(subset) --force --skip-ndb --skip-innodb --skip-im --skip-rpl ; \
+ @PERL@ ./mysql-test-run.pl $(subset) --force --suite=funcs_1 --do-test=myisam
+
+test-fast-view:
+ $(MAKE) subset=--view-protocol test-fast
+
+test-fast-cursor:
+ $(MAKE) subset=--cursor-protocol test-fast
+
+test-fast-prepare:
+ $(MAKE) subset=--ps-protocol test-fast
+
+test-full-qa:
+ $(MAKE) force=--force test-pr \
+ test-binlog-statement test-ext test-fast-view \
+ test-fast-cursor test-unit
+
# Don't update the files from bitkeeper
%::SCCS/s.%