summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavi Arnaut <davi.arnaut@oracle.com>2010-10-13 12:11:29 -0300
committerDavi Arnaut <davi.arnaut@oracle.com>2010-10-13 12:11:29 -0300
commit215e967ace1c5cbcdcaf82d1b00b31bc9f132393 (patch)
tree0474850f6234405da1be770410019f50b4a96f32 /Makefile.am
parente760a4d8ab820e5072149b2c1e86bb0a42f85171 (diff)
downloadmariadb-git-215e967ace1c5cbcdcaf82d1b00b31bc9f132393.tar.gz
Use a guard macro to prevent the inclusion of system headers
when checking the ABI with the C Preprocessor. Also, add the new hearders to the cmake based ABI check. cmake/abi_check.cmake: Add headers which were added to the autotools ABI check. Remove trailing spaces. include/mysql/client_plugin.h: Guard the inclusion of system headers.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fadd73d5094..c47d8e780cf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -263,6 +263,8 @@ test-full-qa:
#
# Headers which need to be checked for abi/api compatibility.
#
+# Attention: do not forget to also add to cmake/abi_check.cmake
+#
API_PREPROCESSOR_HEADER = $(top_srcdir)/include/mysql/plugin_audit.h \
$(top_srcdir)/include/mysql/plugin_ftparser.h \