summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <joerg@trift2.>2007-10-30 20:06:49 +0100
committerunknown <joerg@trift2.>2007-10-30 20:06:49 +0100
commit85ba610f2633842eeb5fa08a02429144e77a5580 (patch)
treef854068763612333d5c9c70688b6d6e3fdba0f6e /Makefile.am
parent4123825d1b77e9ea4b9693d8dc8426d3952e2e2a (diff)
downloadmariadb-git-85ba610f2633842eeb5fa08a02429144e77a5580.tar.gz
Minor Makefile fixes:
1) Add a new top level "Makefile.am" target "make embedded-test". 2) Fix a syntax error (bad merge) in "netware/Makefile.am". Makefile.am: Add a new "make" target "embedded-test" so that it is easier to test the "embedded server" ("libmyslqd"). Make it "phony". Use it via a sub-make within "test-bt" to avoid code duplication. netware/Makefile.am: Cleanup: Macros "BUILT_SOURCES" and "CLEANFILES" should be defined only once.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 11 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index c968c50f6bc..0125f37d44c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,7 +66,7 @@ tags:
test-pl test-force-pl test-full-pl test-force-full-pl test-force-pl-mem \
test-unit test-ps test-nr test-pr test-ns test-binlog-statement \
test-ext-funcs test-ext-rpl test-ext-partitions test-ext-jp \
- test-ext-stress test-ext \
+ test-ext-stress test-ext test-embedded \
test-fast test-fast-cursor test-fast-view test-fast-prepare \
test-full-qa
@@ -101,6 +101,15 @@ test-binlog-statement:
cd mysql-test ; \
@PERL@ ./mysql-test-run.pl $(force) --mysqld=--binlog-format=statement
+test-embedded:
+ if [ -e bin/mysqltest_embedded -o -e libmysqld/examples/mysqltest_embedded ] ; then \
+ cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --comment=embedded --force --timer \
+ --embedded-server --skip-rpl --skip-ndbcluster ; \
+ else \
+ echo "no program found for 'embedded' tests - skipped testing" ; \
+ fi
+
test: test-unit test-ns test-pr
test-full: test test-nr test-ps
@@ -131,11 +140,7 @@ test-bt:
-cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --comment=NDB --force --timer \
--with-ndbcluster-only
- -if [ -e bin/mysqltest_embedded -o -e libmysqld/examples/mysqltest_embedded ] ; then \
- cd mysql-test ; MTR_BUILD_THREAD=auto \
- @PERL@ ./mysql-test-run.pl --comment=embedded --force --timer \
- --embedded-server --skip-rpl --skip-ndbcluster ; \
- fi
+ -$(MAKE) test-embedded
-cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --force --comment=funcs1_ps --ps-protocol --suite=funcs_1
-cd mysql-test ; MTR_BUILD_THREAD=auto \