summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <serg@janus.mylan>2008-01-29 18:15:38 +0100
committerunknown <serg@janus.mylan>2008-01-29 18:15:38 +0100
commitdb58a1378cd5427284cd9f794c19ac286da5f2b1 (patch)
tree6c4ae99b76cbf786c5ff8891aef13324cdbff950 /Makefile.am
parent71eb292f37b25c11fd3d041d38d3397d7ce8ccb7 (diff)
downloadmariadb-git-db58a1378cd5427284cd9f794c19ac286da5f2b1.tar.gz
changes for big unit tests
Makefile.am: make test-unit-big storage/maria/unittest/Makefile.am: support big unit tests storage/maria/unittest/ma_pagecache_consist.c: support big unit tests and other changes storage/maria/unittest/ma_pagecache_single.c: support big unit tests storage/maria/unittest/ma_test_all-t: support big unit tests and sub skip() storage/maria/unittest/ma_test_loghandler-t.c: support big unit tests unittest/unit.pl: don't ignore existing $MYTAP_CONFIG
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 698e49f61f0..12001c4b962 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -64,7 +64,7 @@ tags:
.PHONY: init-db bin-dist \
test test-force test-full test-force-full test-force-mem \
test-pl test-force-pl test-full-pl test-force-full-pl test-force-pl-mem \
- test-unit test-ps test-nr test-pr test-ns test-binlog-statement \
+ test-unit test-unit-big test-ps test-nr test-pr test-ns test-binlog-statement \
test-ext-funcs test-ext-rpl test-ext-partitions test-ext-jp \
test-ext-stress test-ext test-embedded \
test-fast test-fast-cursor test-fast-view test-fast-prepare \
@@ -79,7 +79,10 @@ tags:
# making sure each user use different ports.
test-unit:
- cd unittest && $(MAKE) test
+ cd unittest; $(MAKE) test
+
+test-unit-big:
+ cd unittest; MYTAP_CONFIG=big $(MAKE) test
test-ps:
cd mysql-test ; \