summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorjoerg@trift2. <>2007-12-07 11:54:59 +0100
committerjoerg@trift2. <>2007-12-07 11:54:59 +0100
commit2cf168d6aac6af07a2daa8542fc3742701943f13 (patch)
tree44b4a8a22e9dc2c78a453bbb914116224a036b21 /Makefile.am
parent45307504997c801ef119660576c5b326d061713d (diff)
downloadmariadb-git-2cf168d6aac6af07a2daa8542fc3742701943f13.tar.gz
Makefile.am
In the "test-bt" target, replace the call "$(MAKE) test-embedded" by the actions of that target.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0c9a0d85d26..73eeb425705 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -102,6 +102,7 @@ test-binlog-statement:
@PERL@ ./mysql-test-run.pl $(force) --mysqld=--binlog-format=statement
test-embedded:
+ # This code is duplicated in "test-bt", see the Changeset comment of 2007-Dec-07
if [ -e bin/mysqltest_embedded -o -e libmysqld/examples/mysqltest_embedded ] ; then \
cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --comment=embedded --force --timer \
@@ -140,7 +141,13 @@ test-bt:
-cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --comment=NDB --force --timer \
--with-ndbcluster-only
- -$(MAKE) test-embedded
+ -if [ -e bin/mysqltest_embedded -o -e libmysqld/examples/mysqltest_embedded ] ; then \
+ cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --comment=embedded --force --timer \
+ --embedded-server --skip-rpl --skip-ndbcluster ; \
+ else \
+ echo "no program found for 'embedded' tests - skipped testing" ; \
+ fi
-cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --force --comment=funcs1_ps --ps-protocol --suite=funcs_1
-cd mysql-test ; MTR_BUILD_THREAD=auto \