summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent/mysqldev@mysql.com/production.mysql.com>2008-04-02 22:24:53 +0200
committerunknown <kent/mysqldev@mysql.com/production.mysql.com>2008-04-02 22:24:53 +0200
commite12312d82122cdd3743d05a12015385dd79348b6 (patch)
treeda8d71bcdb0edc87f55864a811eb1fd8f6490de6 /Makefile.am
parent60e5661361070701b374b7e48229b7b3f07492b2 (diff)
downloadmariadb-git-e12312d82122cdd3743d05a12015385dd79348b6.tar.gz
mysql.spec.sh:
If excluding Federated, make sure dynamic plugin is not built Makefile.am: Only run cluster test when compiled with cluster lib_sql.cc: Work around for Visual Studio 2003, that lacks vsnprintf() but has _vsnprintf() Makefile.am: Only run cluster test when compiled with cluster libmysqld/lib_sql.cc: Work around for Visual Studio 2003, that lacks vsnprintf() but has _vsnprintf() support-files/mysql.spec.sh: If excluding Federated, make sure dynamic plugin is not built
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 11 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index ad94c9ea325..f999df86acf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -135,12 +135,17 @@ test-bt:
-cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --comment=normal+rowrepl --force --timer \
--skip-ndbcluster --mysqld=--binlog-format=row
- -cd mysql-test ; MTR_BUILD_THREAD=auto \
- @PERL@ ./mysql-test-run.pl --comment=ps+rowrepl+NDB --force --timer \
- --ps-protocol --mysqld=--binlog-format=row
- -cd mysql-test ; MTR_BUILD_THREAD=auto \
- @PERL@ ./mysql-test-run.pl --comment=NDB --force --timer \
- --with-ndbcluster-only
+ -if [ -e bin/ndbd -o -e storage/ndb/src/kernel/ndbd ] ; then \
+ cd mysql-test ; \
+ MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --comment=ps+rowrepl+NDB --force --timer \
+ --ps-protocol --mysqld=--binlog-format=row ; \
+ MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --comment=NDB --force --timer \
+ --with-ndbcluster-only ; \
+ else \
+ echo "no program found for 'ndbcluster' tests - skipped testing" ; \
+ fi
-if [ -e bin/mysqltest_embedded -o -e libmysqld/examples/mysqltest_embedded ] ; then \
cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --comment=embedded --force --timer \