summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorbrian@zim.(none) <>2005-08-30 14:40:02 -0700
committerbrian@zim.(none) <>2005-08-30 14:40:02 -0700
commit57403ddc9da2a2fa153629f3564c662cb0de405e (patch)
treefb387d75c6bc8131e0d735a74cc6ab053e56c186 /Makefile.am
parentb423cbf2ce44e7abf162b4a59e288c1562a2e39e (diff)
parent2b0c81c984af1ab4d9f30b2d089102a13f507079 (diff)
downloadmariadb-git-57403ddc9da2a2fa153629f3564c662cb0de405e.tar.gz
Merge zim.(none):/home/brian/mysql/mysql-5.0
into zim.(none):/home/brian/mysql/mysql-5.1 Resolved to minor issues.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 18 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 830c68df3f5..80f95d6afff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -105,10 +105,25 @@ test:
cd mysql-test; \
./mysql-test-run && ./mysql-test-run --ps-protocol
+# Test installation. Ports are configurable from the environment.
+
+MYSQL_TEST_MANAGER_PORT = 9305
+MYSQL_TEST_MASTER_PORT = 9306
+MYSQL_TEST_SLAVE_PORT = 9308
+MYSQL_TEST_NDB_PORT = 9350
+MYSQL_TEST_RUN_ARGS = --manager-port=$(MYSQL_TEST_MANAGER_PORT) \
+ --master_port=$(MYSQL_TEST_MASTER_PORT) \
+ --slave_port=$(MYSQL_TEST_SLAVE_PORT) \
+ --ndbcluster_port=$(MYSQL_TEST_NDB_PORT)
+test:
+ cd mysql-test ; \
+ ./mysql-test-run.pl $(MYSQL_TEST_RUN_ARGS) && \
+ ./mysql-test-run.pl --ps-protocol $(MYSQL_TEST_RUN_ARGS)
+
test-force:
- cd mysql-test; \
- ./mysql-test-run --force ;\
- ./mysql-test-run --ps-protocol --force
+ cd mysql-test ; \
+ ./mysql-test-run --force $(MYSQL_TEST_RUN_ARGS) ; \
+ ./mysql-test-run --ps-protocol --force $(MYSQL_TEST_RUN_ARGS)
# Don't update the files from bitkeeper
%::SCCS/s.%