summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <serg@serg.mylan>2006-06-14 09:12:37 +0200
committerunknown <serg@serg.mylan>2006-06-14 09:12:37 +0200
commiteff0000226253bf87d03f1f465c52bee09a679c8 (patch)
treeb69819c22e87492ccd77ab7bd4f4fd98c970686c /Makefile.am
parentb19c1896adea1166adb8e80552ac3abfa7642205 (diff)
downloadmariadb-git-eff0000226253bf87d03f1f465c52bee09a679c8.tar.gz
change test targets to be more modular. include unit tests into make test
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am43
1 files changed, 24 insertions, 19 deletions
diff --git a/Makefile.am b/Makefile.am
index dfa6c7f0f07..8a575b3c365 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -101,7 +101,9 @@ dist-hook:
tags:
support-files/build-tags
-.PHONY: init-db bin-dist
+
+.PHONY: init-db bin-dist test test-full test-ps test-nr \
+ test-ns test-pr test-unit
# Target 'test' will run the regression test suite using the built server.
#
@@ -111,29 +113,34 @@ tags:
# will then calculate the various port numbers it needs from this,
# making sure each user use different ports.
-test:
+test-unit:
+ cd unittest && $(MAKE) test
+
+test-ps:
cd mysql-test ; \
- ./mysql-test-run.pl --mysqld=--binlog-format=statement && \
- ./mysql-test-run.pl --ps-protocol --mysqld=--binlog-format=row
+ ./mysql-test-run.pl $(force) --ps-protocol --mysqld=--binlog-format=statement
-test-full:
+test-nr:
cd mysql-test ; \
- ./mysql-test-run.pl --mysqld=--binlog-format=statement && \
- ./mysql-test-run.pl --ps-protocol --mysqld=--binlog-format=statement && \
- ./mysql-test-run.pl --mysqld=--binlog-format=row && \
- ./mysql-test-run.pl --ps-protocol --mysqld=--binlog-format=row
+ ./mysql-test-run.pl $(force) --mysqld=--binlog-format=row
-test-force:
+test-pr:
cd mysql-test ; \
- ./mysql-test-run.pl --force --mysqld=--binlog-format=statement && \
- ./mysql-test-run.pl --ps-protocol --force --mysqld=--binlog-format=row
+ ./mysql-test-run.pl $(force) --ps-protocol --mysqld=--binlog-format=row
-test-force-full:
+test-ns:
cd mysql-test ; \
- ./mysql-test-run.pl --force --mysqld=--binlog-format=statement && \
- ./mysql-test-run.pl --force --ps-protocol --mysqld=--binlog-format=statement && \
- ./mysql-test-run.pl --force --mysqld=--binlog-format=row && \
- ./mysql-test-run.pl --force --ps-protocol --mysqld=--binlog-format=row
+ ./mysql-test-run.pl $(force) --mysqld=--binlog-format=statement
+
+test: test-unit test-ns test-pr
+
+test-full: test test-nr test-ps
+
+test-force:
+ $(MAKE) force=--force test
+
+test-force-full:
+ $(MAKE) force=--force test-full
# Keep these for a while
test-pl: test
@@ -141,8 +148,6 @@ test-full-pl: test-full
test-force-pl: test-force
test-force-full-pl: test-force-full
-
-
# Don't update the files from bitkeeper
%::SCCS/s.%