summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNarayanan V <v.narayanan@sun.com>2008-08-08 14:30:05 +0530
committerNarayanan V <v.narayanan@sun.com>2008-08-08 14:30:05 +0530
commitc5095f77f89c45048caae9d324cda77de977a14c (patch)
tree30fcd939d206cb1727deb6c43b23c0ca545afd65 /Makefile.am
parenta9775e8507e8c27ceac21800484132b5819e4ccc (diff)
downloadmariadb-git-c5095f77f89c45048caae9d324cda77de977a14c.tar.gz
WL#4380
1) Disabled abi_check rule for all compilers except gcc 2) restored the -dI option to retain the header information.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 409504bddff..91509f68ccc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -58,7 +58,7 @@ dist-hook:
--datadir=$(distdir)/win/data \
--srcdir=$(top_srcdir)
-all-local: abi_check
+all-local: @ABI_CHECK@
tags:
support-files/build-tags
@@ -292,7 +292,7 @@ abi_check_all: $(TEST_PREPROCESSOR_HEADER)
do_abi_check:
set -ex; \
for file in $(abi_headers); do \
- @CC@ -E -nostdinc \
+ @CC@ -E -nostdinc -dI \
-I$(top_srcdir)/include \
-I$(top_srcdir)/include/mysql \
-I$(top_srcdir)/sql \