summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSven Sandberg <sven.sandberg@sun.com>2010-05-12 12:29:02 +0200
committerSven Sandberg <sven.sandberg@sun.com>2010-05-12 12:29:02 +0200
commit29c8c152b26398ce7ad84a9794f229b10ad9d410 (patch)
treefdc6fa5170af0ca2069f7a660703d4629418ed62 /Makefile.am
parent00cd994d6ed301bea8055d5bf71288a90db88652 (diff)
downloadmariadb-git-29c8c152b26398ce7ad84a9794f229b10ad9d410.tar.gz
BUG#50410: rpl_ndb tests should run with binlog_format=row
Problem: The rpl_ndb did not set binlog_format explicitly. Since the default is binlog_format=statement, it means that the suite ran with that. ndb does not support binlog_format=statement, and many tests were skipped because they sourced include/have_binlog_format_row_or_mixed.inc Fix: set binlog_format=row explicitly in the configuration file for the rpl_ndb suite. Makefile.am: Removed duplicate run of rpl_ndb suite with binlog_format=row. Now that rpl_ndb is run with binlog_format=row by default, this run that explicitly changes to binlog_format=row is not needed, because it is covered by the following run. mysql-test/suite/rpl_ndb/my.cnf: cluster only supports binlog_format=row. mysql-test/suite/rpl_ndb/r/rpl_ndb_stm_innodb.result: updated result file mysql-test/suite/rpl_ndb/t/rpl_ndb_stm_innodb.test: This test is supposed to use binlog_format=STATEMENT on master. It uses innodb on master, so statement format is supported.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 821f7e4fd0f..7953b81fb7b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -147,8 +147,8 @@ test-bt:
-if [ -e bin/ndbd -o -e storage/ndb/src/kernel/ndbd ] ; then \
cd mysql-test ; \
MTR_BUILD_THREAD=auto \
- @PERL@ ./mysql-test-run.pl --comment=ndb+rpl_ndb+ps --force --timer \
- --ps-protocol --mysqld=--binlog-format=row --suite=ndb,rpl_ndb ; \
+ @PERL@ ./mysql-test-run.pl --comment=ndb+ps --force --timer \
+ --ps-protocol --mysqld=--binlog-format=row --suite=ndb ; \
MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --comment=ndb --force --timer \
--with-ndbcluster-only ; \