summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <tim@localhost.polyesthetic.msg>2000-08-18 14:49:31 -0400
committerunknown <tim@localhost.polyesthetic.msg>2000-08-18 14:49:31 -0400
commitada1183947ba71b35050fae7ae50923232e398ac (patch)
treed856a5bdf30bea7244c537d3c01a586e03e6ba5b /Makefile.am
parent259c7ea0f84f25d82ec7b818e5b770f0bc7917d3 (diff)
downloadmariadb-git-ada1183947ba71b35050fae7ae50923232e398ac.tar.gz
Change the behavior of --enable-thread-safe-client. It now builds
both a non-threaded libmysqlclient and a threaded libmysqlclient_r. Makefile.am: - build libmysqlclient_r in a separate directory include/global.h: - build libmysqlclient_r in a separate directory libmysql/Makefile.am: - build libmysqlclient_r in a separate directory
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index bd67f65f7c3..f10e60f8c51 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,7 +21,7 @@ TAR = gtar
# These are built from source in the Docs directory
EXTRA_DIST = INSTALL-SOURCE README \
COPYING COPYING.LIB MIRRORS
-SUBDIRS = include @docs_dirs@ @readline_dir@ libmysql client \
+SUBDIRS = include @docs_dirs@ @readline_dir@ @sql_client_dirs@ \
@sql_server_dirs@ scripts tests man \
@bench_dirs@ support-files
@@ -33,6 +33,7 @@ config.h: linked_client_sources linked_server_sources
linked_client_sources:
cd libmysql; $(MAKE) link_sources
+ cd libmysql_r; $(MAKE) link_sources
echo timestamp > linked_client_sources
#avoid recursive make calls in sql directory