summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorsasha@mysql.sashanet.com <>2001-08-27 17:33:11 -0600
committersasha@mysql.sashanet.com <>2001-08-27 17:33:11 -0600
commit608f25be52f3d5e2e8b56c65e477eb7d008a01e0 (patch)
tree0a747a3ef29d7575773417245b77e6f465e37496 /Makefile.am
parenta877b10c2daac6898dacd7a0ec9a9a462581bb44 (diff)
downloadmariadb-git-608f25be52f3d5e2e8b56c65e477eb7d008a01e0.tar.gz
work on MySQL server management daemon
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 70a8140eff5..b7ffd503460 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,12 +24,14 @@ EXTRA_DIST = INSTALL-SOURCE README \
SUBDIRS = include @docs_dirs@ @readline_dir@ \
@thread_dirs@ @pstack_dirs@ @sql_client_dirs@ \
@sql_server_dirs@ @libmysqld_dirs@ scripts tests man \
- @bench_dirs@ support-files @fs_dirs@
+ @bench_dirs@ support-files @fs_dirs@ @tools_dirs@
# Relink after clean
linked_sources = linked_client_sources linked_server_sources \
linked_libmysql_sources linked_libmysql_r_sources \
- linked_libmysqld_sources linked_include_sources
+ linked_libmysqld_sources linked_include_sources \
+ linked_tools_sources
+
CLEANFILES = $(linked_sources)
# This is just so that the linking is done early.
@@ -43,6 +45,11 @@ linked_client_sources: @linked_client_targets@
cd client; $(MAKE) link_sources
echo timestamp > linked_client_sources
+linked_tools_sources:
+ cd tools; $(MAKE) link_sources
+ echo timestamp > linked_tools_sources
+
+
linked_libmysql_sources:
cd libmysql; $(MAKE) link_sources
echo timestamp > linked_libmysql_sources