summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJonathan Perkin <jperkin@sun.com>2008-08-20 12:32:34 +0100
committerJonathan Perkin <jperkin@sun.com>2008-08-20 12:32:34 +0100
commitdff9ccce9ca96c57972d0bef8c726b7a84e2770c (patch)
tree681d59e4a9a7a173b12ac7dc8955420f6116acbe /Makefile.am
parentb9bfa25fb20d410bf83925df9c813beca95025b4 (diff)
downloadmariadb-git-dff9ccce9ca96c57972d0bef8c726b7a84e2770c.tar.gz
bug#33300: use myisamchk to verify that mysql_install_db has
created at least some files and that they are correct.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index fc5138e2778..1061f64a0dd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -49,7 +49,7 @@ bin-dist: all
$(top_builddir)/scripts/make_binary_distribution @MAKE_BINARY_DISTRIBUTION_OPTIONS@
# Remove BK's "SCCS" subdirectories from source distribution
-# Create initial database files for Windows installations.
+# Create initial database files for Windows installations and check them.
dist-hook:
rm -rf `find $(distdir) -type d -name SCCS -print`
mkdir -p $(distdir)/win
@@ -57,6 +57,7 @@ dist-hook:
--builddir=$(top_builddir) \
--datadir=$(distdir)/win/data \
--srcdir=$(top_srcdir)
+ myisam/myisamchk --silent --fast $(distdir)/win/data/mysql/*.MYI
tags:
support-files/build-tags