summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <tsmith/mysqldev@mysql.com/production.mysql.com>2007-11-30 06:14:43 +0100
committerunknown <tsmith/mysqldev@mysql.com/production.mysql.com>2007-11-30 06:14:43 +0100
commit3308d8794eec865679e9d282b6ae3a662d7d212a (patch)
treeba5983792cc687bb7813f0078c9714d849f7e2dd /Makefile.am
parenta6f8ec0b950b674ba3640b336588e8b927f7b92d (diff)
downloadmariadb-git-3308d8794eec865679e9d282b6ae3a662d7d212a.tar.gz
Bug #32219: too many hosts in default grant tables 6.0.3
Fix is to remove any references to the current hostname when running mysql_install_db --cross-bootstrap. (The dist-hook make target makes this call, and the resulting data directory is included in the source distribution as win/data/*.) Also, a few other clean-ups to mysql_install_db while there. Makefile.am: Adapt to clean-up in mysql_install_db (--windows becomes --cross-bootstrap) scripts/mysql_install_db.sh: Filter out references to the current hostname when performing a cross-bootstrap installation by removing any lines which contain the string "@current_hostname". Deprecate the old --windows option; use --cross-bootstrap instead, since it more accurately reflects the purpose. Other clean-up: the wrong syntax was being used to test the exit status of mysqld --bootstrap. It mostly worked, as long as mysqld succeeded. However, it was not robust. scripts/mysql_system_tables_data.sql: Rename local @hostname variable to @current_hostname, which is a more unique label to search on. mysql_install_db now filters out all lines which include "@current_hostname" during a --cross-bootstrap installation.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c1bdbb22e8e..52a9dcbd389 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -102,7 +102,7 @@ dist-hook:
rm -rf `find $(distdir) -type d -name SCCS -print`
rm -f `find $(distdir) -type l -print`
mkdir -p $(distdir)/win
- scripts/mysql_install_db --no-defaults --windows \
+ scripts/mysql_install_db --no-defaults --cross-bootstrap \
--basedir=$(top_builddir) \
--datadir=$(distdir)/win/data \
--srcdir=$(top_srcdir)