summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com>2005-09-24 02:42:38 +0200
committerunknown <kent@mysql.com>2005-09-24 02:42:38 +0200
commit3614cff71cc79b197863a968d385cb2cce1680fd (patch)
treea6b733163d2c8ac90360c92efe24f52a33a8ea0d /Makefile.am
parent5559c48e182e40cfd052a29e875514761994333d (diff)
downloadmariadb-git-3614cff71cc79b197863a968d385cb2cce1680fd.tar.gz
Makefile.am:
Revert to shell test script for test targets mysqltest.c: Windows pclose() returns error code in low byte mysql_config.sh: Remove -Xa -xstrconst from --cflags for Sun C++ scripts/mysql_config.sh: Remove -Xa -xstrconst from --cflags for Sun C++ client/mysqltest.c: Windows pclose() returns error code in low byte Makefile.am: Revert to shell test script for test targets
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ae0d56ba9fd..9025251ff2a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -106,12 +106,12 @@ MYSQL_TEST_NDB_PORT = 9350
test:
cd mysql-test ; \
- ./mysql-test-run.pl \
+ ./mysql-test-run \
--manager-port=$(MYSQL_TEST_MANAGER_PORT) \
--master_port=$(MYSQL_TEST_MASTER_PORT) \
--slave_port=$(MYSQL_TEST_SLAVE_PORT) \
--ndbcluster_port=$(MYSQL_TEST_NDB_PORT) && \
- ./mysql-test-run.pl --ps-protocol \
+ ./mysql-test-run --ps-protocol \
--manager-port=$(MYSQL_TEST_MANAGER_PORT) \
--master_port=$(MYSQL_TEST_MASTER_PORT) \
--slave_port=$(MYSQL_TEST_SLAVE_PORT) \
@@ -121,3 +121,14 @@ test-force:
cd mysql-test; \
./mysql-test-run --force ;\
./mysql-test-run --ps-protocol --force
+
+# We are testing a new Perl version of the test script
+test-pl:
+ cd mysql-test; \
+ ./mysql-test-run.pl && \
+ ./mysql-test-run.pl --ps-protocol
+
+test-force-pl:
+ cd mysql-test; \
+ ./mysql-test-run.pl --force ; \
+ ./mysql-test-run.pl --ps-protocol --force