summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorkent@mysql.com <>2005-09-29 19:37:03 +0200
committerkent@mysql.com <>2005-09-29 19:37:03 +0200
commit3b906e73d82c9d164e962c4dd98e150a485cd0b7 (patch)
tree63e9b3c73700eaf4a957b9689e02185d08ac8de9 /Makefile.am
parent44b4e9fc822c124d8f52ce908a20472b199434e2 (diff)
downloadmariadb-git-3b906e73d82c9d164e962c4dd98e150a485cd0b7.tar.gz
portability.h:
Corrected OpenServer ifdef test Makefile.am: Added test-pl and test-force-pl targets
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am32
1 files changed, 19 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index 3be3ce80b71..403a4ba2137 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -107,20 +107,26 @@ MYSQL_TEST_RUN_ARGS = --manager-port=$(MYSQL_TEST_MANAGER_PORT) \
--master_port=$(MYSQL_TEST_MASTER_PORT) \
--slave_port=$(MYSQL_TEST_SLAVE_PORT) \
--ndbcluster_port=$(MYSQL_TEST_NDB_PORT)
+
test:
cd mysql-test ; \
- ./mysql-test-run \
- --manager-port=$(MYSQL_TEST_MANAGER_PORT) \
- --master_port=$(MYSQL_TEST_MASTER_PORT) \
- --slave_port=$(MYSQL_TEST_SLAVE_PORT) \
- --ndbcluster_port=$(MYSQL_TEST_NDB_PORT) && \
- ./mysql-test-run --ps-protocol \
- --manager-port=$(MYSQL_TEST_MANAGER_PORT) \
- --master_port=$(MYSQL_TEST_MASTER_PORT) \
- --slave_port=$(MYSQL_TEST_SLAVE_PORT) \
- --ndbcluster_port=$(MYSQL_TEST_NDB_PORT)
+ ./mysql-test-run $(MYSQL_TEST_RUN_ARGS) && \
+ ./mysql-test-run $(MYSQL_TEST_RUN_ARGS) --ps-protocol
test-force:
- cd mysql-test; \
- ./mysql-test-run --force ;\
- ./mysql-test-run --ps-protocol --force
+ cd mysql-test ; \
+ ./mysql-test-run $(MYSQL_TEST_RUN_ARGS) --force ; \
+ ./mysql-test-run $(MYSQL_TEST_RUN_ARGS) --ps-protocol --force
+
+test-pl:
+ cd mysql-test ; \
+ ./mysql-test-run.pl $(MYSQL_TEST_RUN_ARGS) && \
+ ./mysql-test-run.pl $(MYSQL_TEST_RUN_ARGS) --ps-protocol
+
+test-force-pl:
+ cd mysql-test ; \
+ ./mysql-test-run.pl $(MYSQL_TEST_RUN_ARGS) --force ; \
+ ./mysql-test-run.pl $(MYSQL_TEST_RUN_ARGS) --ps-protocol --force
+
+# Don't update the files from bitkeeper
+%::SCCS/s.%