summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorkent@mysql.com <>2005-10-25 02:27:55 +0200
committerkent@mysql.com <>2005-10-25 02:27:55 +0200
commit257b17ba2f9cf3d227365e59875f4162b015b3fb (patch)
treea7cb555863d0372b98447a339f926654d3f38d43 /Makefile.am
parentc93927eef02715da9cb3d2be87f769f6667bc78e (diff)
downloadmariadb-git-257b17ba2f9cf3d227365e59875f4162b015b3fb.tar.gz
Makefile.am:
Option to set environment variable MTR_BUILD_THREAD to a small number, from what mysql-test-run calculate port numbers that will not conflict with other runs with different thread num
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 8 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index be2d34f8db8..35c5a51caf4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -85,15 +85,14 @@ tags:
support-files/build-tags
.PHONY: init-db bin-dist
-# Test installation. Ports are configurable from the environment.
-
-MYSQL_TEST_MANAGER_PORT = 9305
-MYSQL_TEST_MASTER_PORT = 9306
-MYSQL_TEST_SLAVE_PORT = 9308
+# Target 'test' will run the regression test suite using the built server.
+#
+# If you are running in a shared environment, users can avoid clashing
+# port numbers by setting individual small numbers 1-100 to the
+# environment variable MTR_BUILD_THREAD. The script "mysql-test-run"
+# will then calculate the various port numbers it needs from this,
+# making sure each user use different ports.
test:
cd mysql-test ; \
- ./mysql-test-run \
- --manager-port=$(MYSQL_TEST_MANAGER_PORT) \
- --master_port=$(MYSQL_TEST_MASTER_PORT) \
- --slave_port=$(MYSQL_TEST_SLAVE_PORT)
+ ./mysql-test-run