summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <hf@deer.(none)>2003-05-31 15:15:46 +0500
committerunknown <hf@deer.(none)>2003-05-31 15:15:46 +0500
commit62c7d2cd2711d3ab2b7d0adba2947b38168cc4b3 (patch)
tree4dd324e7d5c4509bfa76cfb1ebecf8f75b9cc6f5 /Makefile.am
parent598f7ec5e353e7b601c6ade67031f0e74587a501 (diff)
downloadmariadb-git-62c7d2cd2711d3ab2b7d0adba2947b38168cc4b3.tar.gz
SCRUM:
Here is another pack of changes about gathering common client code in sql-common/client.c. Now i symlink the client.c from sql/ and libmysql/. These directories have client_settings.h files to be included to client.c. It contains defines and declarations to compile client.c in appropriate manner. Also i've added include/sql_common.h, containing declarations of what is exported from client.c I removed as many #ifdef-s from client.c as i dared to. I think it's better push it with some extra #ifdef-s now (of course, if everythihg besides it is ok) so other people can check the code. Makefile.am: symlinking of sql-common/client.c was added include/mysql.h: MYSQL_CLIENT define moved here from libmysql/Makefile libmysql/Makefile.am: ../libmysql/client_settings.h added to the list of necessary h-files libmysql/Makefile.shared: client.lo added to the list of objects libmysql/libmysql.c: a lot of changes about separating code between libmysql.c and client.c mysys/default.c: changed to keep compiler happy sql-common/client.c: a lot of changes about code separating sql/Makefile.am: mini_client.h has to be removed sql/repl_failsafe.cc: mysql_real_connect prototype was unified, so we've got to set connection timeout separately sql/slave.cc: trimming code to the changed function's prototypes sql/sql_repl.cc: mini_client isn't needed anymore
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 26c26357400..1fcf498a84b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -70,7 +70,10 @@ linked_netware_sources:
#avoid recursive make calls in sql directory
linked_server_sources:
- cd sql; rm -f mini_client_errors.c;@LN_CP_F@ ../libmysql/errmsg.c mini_client_errors.c; rm -f pack.c;@LN_CP_F@ ../sql-common/pack.c pack.c
+ cd sql; rm -f mini_client_errors.c;\
+ @LN_CP_F@ ../libmysql/errmsg.c mini_client_errors.c;\
+ rm -f pack.c;@LN_CP_F@ ../sql-common/pack.c pack.c;\
+ rm -f client.c;@LN_CP_F@ ../sql-common/client.c client.c
echo timestamp > linked_server_sources
# Create permission databases