summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <joerg@trift2.>2007-12-07 11:54:59 +0100
committerunknown <joerg@trift2.>2007-12-07 11:54:59 +0100
commit128a754f0c6f12b89030dc275a2c972c7c95a207 (patch)
tree44b4a8a22e9dc2c78a453bbb914116224a036b21 /Makefile.am
parent9b6dc66ede4f939ad123f4a18a0a883f529d4963 (diff)
downloadmariadb-git-128a754f0c6f12b89030dc275a2c972c7c95a207.tar.gz
Makefile.am
In the "test-bt" target, replace the call "$(MAKE) test-embedded" by the actions of that target. Makefile.am: In the "test-bt" target, replace the call "$(MAKE) test-embedded" by the actions of that target. Reason: For release builds, we run the tests in a tree that contains just a binary installation. So the Makefile is not in the test tree, and we explicitly address it in the build tree. This explicit path is not kept by "make", so it is missing in the sub-make. There seems to be no way to solve this with (portable!) "make" features - we could add a new variable and use it in the sub-make, but it is easier to duplicate these few lines.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0c9a0d85d26..73eeb425705 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -102,6 +102,7 @@ test-binlog-statement:
@PERL@ ./mysql-test-run.pl $(force) --mysqld=--binlog-format=statement
test-embedded:
+ # This code is duplicated in "test-bt", see the Changeset comment of 2007-Dec-07
if [ -e bin/mysqltest_embedded -o -e libmysqld/examples/mysqltest_embedded ] ; then \
cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --comment=embedded --force --timer \
@@ -140,7 +141,13 @@ test-bt:
-cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --comment=NDB --force --timer \
--with-ndbcluster-only
- -$(MAKE) test-embedded
+ -if [ -e bin/mysqltest_embedded -o -e libmysqld/examples/mysqltest_embedded ] ; then \
+ cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --comment=embedded --force --timer \
+ --embedded-server --skip-rpl --skip-ndbcluster ; \
+ else \
+ echo "no program found for 'embedded' tests - skipped testing" ; \
+ fi
-cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --force --comment=funcs1_ps --ps-protocol --suite=funcs_1
-cd mysql-test ; MTR_BUILD_THREAD=auto \