summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authortim@localhost.polyesthetic.msg <>2000-08-18 14:49:31 -0400
committertim@localhost.polyesthetic.msg <>2000-08-18 14:49:31 -0400
commitcf2e115ec3d91dc9e3148f7bef0f37720df19602 (patch)
treed856a5bdf30bea7244c537d3c01a586e03e6ba5b /Makefile.am
parent86f4dbe20e850a6161d69b7407838c28a8bf93f9 (diff)
downloadmariadb-git-cf2e115ec3d91dc9e3148f7bef0f37720df19602.tar.gz
Change the behavior of --enable-thread-safe-client. It now builds
both a non-threaded libmysqlclient and a threaded libmysqlclient_r.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index bd67f65f7c3..f10e60f8c51 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,7 +21,7 @@ TAR = gtar
# These are built from source in the Docs directory
EXTRA_DIST = INSTALL-SOURCE README \
COPYING COPYING.LIB MIRRORS
-SUBDIRS = include @docs_dirs@ @readline_dir@ libmysql client \
+SUBDIRS = include @docs_dirs@ @readline_dir@ @sql_client_dirs@ \
@sql_server_dirs@ scripts tests man \
@bench_dirs@ support-files
@@ -33,6 +33,7 @@ config.h: linked_client_sources linked_server_sources
linked_client_sources:
cd libmysql; $(MAKE) link_sources
+ cd libmysql_r; $(MAKE) link_sources
echo timestamp > linked_client_sources
#avoid recursive make calls in sql directory