summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorhf@deer.(none) <>2003-05-31 15:15:46 +0500
committerhf@deer.(none) <>2003-05-31 15:15:46 +0500
commit02d3d7e8bd0b5a582befe8d02d41c9cca1bcfe8e (patch)
tree4dd324e7d5c4509bfa76cfb1ebecf8f75b9cc6f5 /Makefile.am
parent6bc3473f8883783f4613d25af99f89f06b12c600 (diff)
downloadmariadb-git-02d3d7e8bd0b5a582befe8d02d41c9cca1bcfe8e.tar.gz
SCRUM:
Here is another pack of changes about gathering common client code in sql-common/client.c. Now i symlink the client.c from sql/ and libmysql/. These directories have client_settings.h files to be included to client.c. It contains defines and declarations to compile client.c in appropriate manner. Also i've added include/sql_common.h, containing declarations of what is exported from client.c I removed as many #ifdef-s from client.c as i dared to. I think it's better push it with some extra #ifdef-s now (of course, if everythihg besides it is ok) so other people can check the code.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 26c26357400..1fcf498a84b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -70,7 +70,10 @@ linked_netware_sources:
#avoid recursive make calls in sql directory
linked_server_sources:
- cd sql; rm -f mini_client_errors.c;@LN_CP_F@ ../libmysql/errmsg.c mini_client_errors.c; rm -f pack.c;@LN_CP_F@ ../sql-common/pack.c pack.c
+ cd sql; rm -f mini_client_errors.c;\
+ @LN_CP_F@ ../libmysql/errmsg.c mini_client_errors.c;\
+ rm -f pack.c;@LN_CP_F@ ../sql-common/pack.c pack.c;\
+ rm -f client.c;@LN_CP_F@ ../sql-common/client.c client.c
echo timestamp > linked_server_sources
# Create permission databases