summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com>2005-11-04 01:15:35 +0100
committerunknown <kent@mysql.com>2005-11-04 01:15:35 +0100
commit21c0c02705c0ba4695b202a6f4d7cd418fd13331 (patch)
treea0700217b074f5374b745569de7a1f521d31d856 /Makefile.am
parente515af86fb9b93ea16cea24c426cf5e831e81d2b (diff)
parentdc6117efa606f8e84d1196f474a64d380a73280d (diff)
downloadmariadb-git-21c0c02705c0ba4695b202a6f4d7cd418fd13331.tar.gz
Merge kboortz@bk-internal.mysql.com:/home/bk/mysql-4.1
into mysql.com:/Users/kent/mysql/bk/mysql-4.1-distcheck Makefile.am: Auto merged configure.in: Auto merged mysql-test/Makefile.am: Auto merged
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am31
1 files changed, 15 insertions, 16 deletions
diff --git a/Makefile.am b/Makefile.am
index 2b0ea0c3dde..2aefbd05283 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,8 @@
AUTOMAKE_OPTIONS = foreign
# These are built from source in the Docs directory
-EXTRA_DIST = INSTALL-SOURCE README COPYING EXCEPTIONS-CLIENT
+EXTRA_DIST = INSTALL-SOURCE INSTALL-WIN-SOURCE \
+ README COPYING EXCEPTIONS-CLIENT
SUBDIRS = . include @docs_dirs@ @zlib_dir@ \
@readline_topdir@ sql-common \
@thread_dirs@ pstack \
@@ -34,16 +35,19 @@ DIST_SUBDIRS = . include @docs_dirs@ zlib \
BUILD netware os2 @libmysqld_dirs@ \
@bench_dirs@ support-files @fs_dirs@ @tools_dirs@
-# Relink after clean
-linked_sources = linked_client_sources linked_server_sources \
- linked_libmysql_sources linked_libmysql_r_sources \
- linked_libmysqld_sources linked_libmysqldex_sources \
+# Run these targets before any others, also make part of clean target,
+# to make sure we create new links after a clean.
+BUILT_SOURCES = linked_client_sources linked_server_sources \
+ @linked_client_targets@ \
+ @linked_libmysqld_targets@ \
linked_include_sources @linked_netware_sources@
-CLEANFILES = $(linked_sources)
-
-# This is just so that the linking is done early.
-all-local: $(linked_sources)
+# The db.h file is a bit special, see note in "configure.in".
+# In the case we didn't compile with bdb, a dummy file is put
+# there, but will not be removed by the bdb make file becuase
+# it will never be called.
+CLEANFILES = $(BUILT_SOURCES) bdb/build_unix/db.h
+DISTCLEANFILES = ac_available_languages_fragment
linked_include_sources:
cd include; $(MAKE) link_sources
@@ -73,13 +77,8 @@ linked_netware_sources:
cd @netware_dir@; $(MAKE) link_sources
echo timestamp > linked_netware_sources
-#avoid recursive make calls in sql directory
linked_server_sources:
- cd sql; rm -f mini_client_errors.c;\
- @LN_CP_F@ ../libmysql/errmsg.c mini_client_errors.c;\
- rm -f pack.c;@LN_CP_F@ ../sql-common/pack.c pack.c;\
- rm -f client.c;@LN_CP_F@ ../sql-common/client.c client.c;\
- rm -f my_time.c;@LN_CP_F@ ../sql-common/my_time.c my_time.c
+ cd sql; $(MAKE) link_sources
echo timestamp > linked_server_sources
# Create permission databases
@@ -91,7 +90,7 @@ bin-dist: all
# Remove BK's "SCCS" subdirectories from source distribution
dist-hook:
- rm -rf `find $(distdir) -type d -name SCCS`
+ rm -rf `find $(distdir) -type d -name SCCS -print`
tags:
support-files/build-tags